VMware Cloud Community
amsteel
Contributor
Contributor

Esxi 6.5.0 Update 3 guest console not working

Windows 10 guest on Esxi 6.5.0 Update 3. The guest console is not working. The web console just show blue background with "vmware". Show menu items but none of them is working. For example nothing happens if I chose shutdown from the console menu.

The web gui of esxi works and I can shutdown the VM from the web gui. Here is the log I found under the vm:

2020-06-03T14:10:45.072Z| vmx| I125: VigorTransportProcessClientPayload: opID=esxui-444-2c49 seq=58802: Receiving MKS.IssueTicket request.

2020-06-03T14:10:45.072Z| vmx| I125: SOCKET 132 (113) creating new listening socket on port -1

2020-06-03T14:10:45.072Z| vmx| I125: Issuing new webmks ticket 4efa17... (120 seconds)

2020-06-03T14:10:45.072Z| vmx| I125: VigorTransport_ServerSendResponse opID=esxui-444-2c49 seq=58802: Completed MKS request.

2020-06-03T14:10:45.201Z| mks| I125: Accepting connection for webmks ticket 4efa17...

2020-06-03T14:10:45.201Z| mks| I125: Expiring webmks ticket 4efa17...

2020-06-03T14:10:45.201Z| mks| I125: MKS-RemoteMgr: Negotiated Web Socket protocol=binary

2020-06-03T14:10:45.201Z| mks| W115: SOCKET 133 (146) unable to determine remote IP address

2020-06-03T14:10:45.202Z| mks| I125: SOCKET 133 (146) Creating VNC remote connection.

2020-06-03T14:10:45.202Z| mks| I125: MKSControlMgr: New VNC connection 4

2020-06-03T14:10:45.586Z| mks| I125: SOCKET 133 (146) Received websocket close frame with empty status code

2020-06-03T14:10:45.586Z| mks| I125: SOCKET 133 (146) Sending websocket close frame, status code = 1000

2020-06-03T14:10:45.586Z| mks| I125: SOCKET 133 (146) VNC Remote Disconnect: socket closed.

2020-06-03T14:10:45.586Z| mks| I125: MKSControlMgr: Remove VNC connection 4

The alternative I am using now is connect to the VM using VNC.

Tested on different workstations, one on the same LAN segment, one behind a router. Same results. Port scan from both workstation shows port 443 and 902 are open.

Any idea how to trouble-shoot this?

Thanks

4 Replies
gibarra94
Enthusiast
Enthusiast

Hi there!

Have you tried to configure VMware Remote Console 11.0 to use the legacy connection mode?

To do so, open the VMware preferences file on the host machine and add the following parameter:


pref.preferWebMKS = "FALSE"

The preferences file can be found in the following location: %APPDATA%\VMware\preferences.ini|

I hope this could solve your issue

Regards

berndweyand
Expert
Expert

can you resolve your hosts ? has it a valid dns record ?

Reply
0 Kudos
amsteel
Contributor
Contributor

I am using IP address to access the esxi. I can open the webgui with no issue.

Reply
0 Kudos
amsteel
Contributor
Contributor

Thanks for the suggestion. That solves the issue on the workstation I had VMRC installed when opening the console using VMRC.

It did not help with web console though.

Reply
0 Kudos