Box293
Enthusiast
Enthusiast

EqualLogic Multipathing Extension Module - Issues with binding using setup.pl

Jump to solution

I keep getting this error when I try and get the EqualLogic Multipathing Extension Module to configure my ESXi 4.1 box.

Could not bind vmk1 to any of the iSCSI adapters.

I have a Dell M710 server. It has the Broadcom 57711 NICs with hardware iSCSI dependant adapters.

Here are the steps to reproduce the problem:

Installed ESXi 4.1 on M710 host

Configured ESXi host with a password

Configured ESXi host with IP Address settings

Connected to my vMA host (that has a local copy of the DELL-eql-mem-1.0.0.130413)

vifp addserver 192.168.110.63

vifptarget -s 192.168.110.63

./setup.pl --install --server=192.168.110.63 --bundle=dell-eql-mem-1.0.0.130413.zip

I then reboot the ESXi host

Once rebooted

vifptarget -s 192.168.110.63

./setup.pl --configure --server=192.168.110.63 --vswitch=vSwitchISCSI --mtu=1500 --nics=vmnic6 --ips=192.168.102.98 --netmask=255.255.255.0 --vmkernel=iSCSI --groupip=192.168.102.40

This then produces the following output:

Configuring networking for iSCSI multipathing:

vswitch = vSwitchISCSI

mtu = 1500

nics = vmnic6

ips = 192.168.102.98

netmask = 255.255.255.0

vmkernel = iSCSI

EQL group IP = 192.168.102.40

Creating vSwitch vSwitchISCSI.

Setting vSwitch MTU to 1500.

Creating portgroup iSCSI0 on vSwitch vSwitchISCSI.

Assigning IP address 192.168.102.98 to iSCSI0.

Creating new bridge.

Adding uplink vmnic6 to vSwitchISCSI.

Setting new uplinks for vSwitchISCSI.

Setting uplink for iSCSI0 to vmnic6.

Could not bind vmk1 to any of the iSCSI adapters.

Argh

So I use the vSphere Client to delete the switch it created (and the vmk ports etc)

I then retry, this time with software iSCSI instead of hardware iSCSI

./setup.pl --configure --server=192.168.110.63 --vswitch=vSwitchISCSI --mtu=1500 --nics=vmnic6 --ips=192.168.102.98 --netmask=255.255.255.0 --vmkernel=iSCSI --nohwiscsi --enableswiscsi --groupip=192.168.102.40

This produces the following output:

Configuring networking for iSCSI multipathing:

vswitch = vSwitchISCSI

mtu = 1500

nics = vmnic6

ips = 192.168.102.98

netmask = 255.255.255.0

vmkernel = iSCSI

enableswiscsi = 1

nohwiscsi = 1

EQL group IP = 192.168.102.40

Creating vSwitch vSwitchISCSI.

Setting vSwitch MTU to 1500.

Creating portgroup iSCSI0 on vSwitch vSwitchISCSI.

Assigning IP address 192.168.102.98 to iSCSI0.

Creating new bridge.

Adding uplink vmnic6 to vSwitchISCSI.

Setting new uplinks for vSwitchISCSI.

Setting uplink for iSCSI0 to vmnic6.

Enabling SW initiator.

Enabled SW initiator.

Could not bind vmk1 to any of the iSCSI adapters.

Argh again.

What am I missing here? The commands I am using for setup.pl are actually given to me by setup.pl when I use the --configure command:

./setup.pl --configure --server=192.168.110.63

It has a nice wizard that asks you all the questions and then tells you what the actual command to use is.

I know my steps are only using 1 nic however I started off using 2 nics and 2 IP's but it gave me the same error. For troubleshooting purposes I decided to only use 1 nic and 1 IP to test. I have also tried vmnic7 instead of vmnic6 with a different IP but no luck.

I have tried a fresh install of ESXi twice.

A whopping 10 points to anyone who can solve my problem :smileysilly:

VCP3 & VCP4 32846

VSP4

VTSP4

Updated the commands used, I was incorrectly using vifp instead of vifptarget, problem still exists but wanted to correct this error.

VCP3 & VCP4 32846 VSP4 VTSP4
0 Kudos
1 Solution

Accepted Solutions
glynnd1
Expert
Expert

Box293,

What I think that has occurred is that vmk1 is already bound to something, be it the software iSCSI adapter or a hardware iSCSI adapter, possible from earlier attempts, or possible from having had the traditional Fixed Path setup on this server - less certain about this second possibility.

Deleting a vmk from the GUI does not undo the bindings, this needs to be done from the CLI with the "esxcli swisici" command.

esxcli swiscsi nic list -d vmhba37 ## this will list all the NIC(s) bound to hardware/software iSCSI adapter

esxcli swiscsi nic remove -n vmk1 -d vmhba37 ## this will unbind vmk1

Doing these steps should help you clean up any binding that you have.

A lazy way to clean up the binding would be to re-install ESXi Smiley Happy

Hope this helps.

David

Dell | EqualLogic employee

View solution in original post

0 Kudos
4 Replies
logiboy123
Expert
Expert

Have you tried the Virtualization Buster writeup for the Dell MEM?

http://www.virtualizationbuster.com/?p=380

For troubleshooting I would try to use a nic that doesn't have TCP/IP offloading. This is because ESX sometimes see's this card as a Hardware Initiator when you want to use it as a software initiator. You can look in storage views to see what vmhba your nic is registered as. On a DL380 G7 for example the first 4 nics are TCP/IP offloaders, so there is vmhba31-34 and then the software initiator is vmhba37.

I would then try to setup the switch and bind the nics manually to see if it can be done. The following link is a walk through for doing this when using a LeftHand SAN, but the steps should still apply for setting up the switch and ports manually.

http://www.scribd.com/doc/24586958/Configuring-Left-Hand-ISCSI-and-VSPHERE-MPIO

If setting up the switch and ports manually works, then its probably something wrong with the script.

Cheers,

logiboy123

glynnd1
Expert
Expert

Box293,

What I think that has occurred is that vmk1 is already bound to something, be it the software iSCSI adapter or a hardware iSCSI adapter, possible from earlier attempts, or possible from having had the traditional Fixed Path setup on this server - less certain about this second possibility.

Deleting a vmk from the GUI does not undo the bindings, this needs to be done from the CLI with the "esxcli swisici" command.

esxcli swiscsi nic list -d vmhba37 ## this will list all the NIC(s) bound to hardware/software iSCSI adapter

esxcli swiscsi nic remove -n vmk1 -d vmhba37 ## this will unbind vmk1

Doing these steps should help you clean up any binding that you have.

A lazy way to clean up the binding would be to re-install ESXi Smiley Happy

Hope this helps.

David

Dell | EqualLogic employee

0 Kudos
Box293
Enthusiast
Enthusiast

Thanks for both posts, I'll give them a go and get back to you.

This might take a week as the server I used for testing was needed for an emergency last night so I am going to need to sort out that issue first ...

VCP3 & VCP4 32846

VSP4

VTSP4

VCP3 & VCP4 32846 VSP4 VTSP4
0 Kudos
Box293
Enthusiast
Enthusiast

Hi David,

It seems a fresh install of ESXi was the go. I've done this twice now and the script completes successfully.

Cheers Smiley Happy

VCP3 & VCP4 32846 VSP4 VTSP4
0 Kudos