VMware Cloud Community

Enable Wake-on-LAN for ESXI Server itself

I am wondering if I can use WOL support to start ESXI myself. I have a Dell R720 that I use in a home lab that I want to start only when I need it.

What command can I type to enable the NICs WOL support and tell ESXI server to start when that happens?

(see the error below)

Here is what I can see:

[root@esxi:~] esxcli network nic get -n vmnic3
Advertised Auto Negotiation: true
Advertised Link Modes: Auto, 1000BaseT/Full, 100BaseT/Half, 100BaseT/Full, 10BaseT/Half, 10BaseT/Full
Auto Negotiation: true
Cable Type: Twisted Pair
Current Message Level: 7
Driver Info:
Bus Info: 0000:02:00:1
Driver: ntg3
Firmware Version: bc 1.30 ncsi
Link Detected: true
Link Status: Up
Name: vmnic3
PHYAddress: 0
Pause Autonegotiate: true
Pause RX: true
Pause TX: true
Supported Ports: TP
Supports Auto Negotiation: true
Supports Pause: true
Supports Wakeon: true
Transceiver: internal
Virtual Address: 00:50:56:54:12:61
Wakeon: Disabled


[root@esxi:~] esxcli network nic list
Name PCI Device Driver Admin Status Link Status Speed Duplex MAC Address MTU Description
------ ------------ ------ ------------ ----------- ----- ------ ----------------- ---- -----------
vmnic0 0000:01:00.0 ntg3 Up Down 0 Half 90:b1:1c:06:31:f4 1500 Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic1 0000:01:00.1 ntg3 Up Down 0 Half 90:b1:1c:06:31:f5 1500 Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic2 0000:02:00.0 ntg3 Up Down 0 Half 90:b1:1c:06:31:f6 1500 Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet
vmnic3 0000:02:00.1 ntg3 Up Up 1000 Full 90:b1:1c:06:31:f7 1500 Broadcom Corporation NetXtreme BCM5720 Gigabit Ethernet


[root@esxi:~] esxcli network nic set -n vmnic3 -w g
Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Not supported

2022-02-26T16:09:42.653Z cpu23:1048692)ntg3:vmnic3:Ntg3SetWolState:999:WOL currently disabled in NVRAM. Please change WOL setting in NVRAM through NIC mgmt software and reboot.

0 Kudos
4 Replies

Not sure what you want to do from the ESXi host's CLI.

You'd usually configure WOL in the physical system BIOS, and use a WOL-Utlility to wake up the host.


0 Kudos

Unfortunatelly this is only half true.

Off course, NIC must feature WOL and WOL must be correct configured in the bios.

But in additon the OS must sent the NIC in an active WOL State when shutting down the system.


I have the same problem here. Windows 10 installed, WOL no problem.

ESXi 8 installed and no WOL possible. But, if i start the system and then press power button to turn in of before ESXi loads, WOL works.

So it is clearly a configuration in ESXi itself.

I have a HP Z2 with a Intel I219LM-PCIe-GbE-Controller and ESXi 8 free version.

I tried: https://documentacoes.wordpress.com/2017/09/04/enable-wol-in-vmware-host/

But ethtool does not seem to work.

I also tried to enable vmotion in the management interface, helped none.

esxcli network nic get -n vmnic0 | grep Wakeon gives "true".

Any option to activate WOL in ESXi 8 free?


Hi, I'd be interested how to make that work as well. I am planning to buy a new server for ESX and have the same requirement! Thx Martin

0 Kudos

I am using low power SBC with Ubuntu 20.04 to wakeonlan <mac_address> ESX 8.
Works like a charm.
Host is old HP desktop with NIC that supports WOL

0 Kudos