rvkrish25
Contributor
Contributor

EXSi 5.5 Cli Upgrade Error

Hi All,

Iam in progress of EXSi 5.5 patch upgrade via CLI getting as

# esxcli software vib update -d "/vmfs/volumes/584ef5b6-e4f48537-8433-0cc47a0a4344/ESXi550-201608001.zip"

[DependencyError]

VIB VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633 requires xhci-xhci >= 1.0-3vmw.550.3.89, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

Please let me know right solution to fix this issue

Thanks

Venkat

6 Replies
rshell
Enthusiast
Enthusiast

rvkrish,

Looks like you are missing that vib. Try running a profile update. Here is an article detailing the process. Also, check out this previous thread for more detail.

0 Kudos
hypervisorboy
Enthusiast
Enthusiast

Hi,

Please follow the below workaround to solve the problem

1.Migrate/Shutdown the VM's from one host because we need to reboot the host

2.Upload the update package (.zip file.) to any Datastore on the host you’re planning to update.

3. Run this command to do the Image Profile update:- esxcli software profile update –depot=/vmfs/volumes/DATASTORE/Update/ESXi550-201608001.zip -p ESXi-5.5.0-20160804001-standard

4.Reboot the host

Please let me know if it helps you.

Thank you Karanveer [VCP6,CCNA,NPP,NSS} if you find this or any other answer useful please mark the answer as correct or helpful.
rvkrish25
Contributor
Contributor

Hi,

Thanks for you update

Iam getting

# esxcli software profile update –depot=/vmfs/volumes/584003fd-ca24f980-7cb5-001a64c2dab0/ESXi550-201608001_4179633_Patch8.zip -p ESXi-5.5.0-20160804001-standard

Error: Unknown command or namespace software profile update –depot=/vmfs/volumes/584003fd-ca24f980-7cb5-001a64c2dab0/ESXi550-201608001_4179633_Patch8.zip

Please advice what I have missed

Thanks

Venkat

0 Kudos
rvkrish25
Contributor
Contributor

Hi,

Have tried the below no luck

~ # esxcli software vib install -d /tmp/VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633.vib

[MetadataDownloadError]

Could not download from depot at /tmp/VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633.vib/index.xml, skipping (('/tmp/VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633.vib/index.xml', '', "[Errno 4] IOError: <urlopen error [Errno 20] Not a directory: '/tmp/VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633.vib/index.xml'>"))

        url = /tmp/VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633.vib/index.xml

Please refer to the log file for more details.

~ # esxcli software vib install -v /tmp/VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633.vib

[DependencyError]

VIB VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633 requires xhci-xhci >= 1.0-3vmw.550.3.89, but the requirement cannot be satisfied within the ImageProfile.

VIB VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.550.3.89.4179633 requires misc-drivers >= 5.5.0-3.89, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

Thanks

0 Kudos
rehall
Contributor
Contributor

This worked for me to change from update to install and allowed me to install the additional patches using the update command

esxcli software vib install -d /path/2/xml

0 Kudos
fellyppe
Contributor
Contributor

Hi hypervisorboy

i execute

esxcli software profile update -d "/vmfs/volumes/datastore1/patch/ESXi550-201608001.zip" -p ESXi-5.5.0-20160804001-standard

And it works! Smiley Happy Thank you!

"–depot=" not work

0 Kudos