Rootdet
Contributor
Contributor

EXSI 7 Missing Vibs

Hi All,

I am working on upgrading the environment to 7.0. I did the usual, downloaded the vmware ISO, added it to the repository, created a baseline and attached it to a host. I then performed a scan and the result came back as "incompatible". The details say this

 

 

The upgrade has VIBs that are missing dependencies:
VMware_bootbank_net-qlge_3.0.0.57-1vmw.550.0.0.1198611
QLC_bootbank_scsi-qedil_1.0.22.0-1OEM.600.0.0.2494585
QLC_bootbank_scsi-qedil_1.0.22.0-1OEM.600.0.0.2494585
QLC_bootbank_scsi-qedil_1.0.22.0-1OEM.600.0.0.2494585
QLC_bootbank_scsi-qedil_1.0.22.0-1OEM.600.0.0.2494585
QLC_bootbank_qedf_1.2.24.5-1OEM.600.0.0.2768847
QLC_bootbank_qedf_1.2.24.5-1OEM.600.0.0.2768847
QLC_bootbank_qedf_1.2.24.5-1OEM.600.0.0.2768847
INT_bootbank_igbn_1.4.1-1OEM.600.0.0.2768847
VMware_bootbank_net-qlge_3.0.0.57-1vmw.550.0.0.1198611

 

 

I did a quick google search and could not find them. QLC hinted it could have been a Dell OEM install disk. so i downloaded the Dell OEM Custom ISO from vmware, ran a scan and comes back incompatible again, this time with just this for missing vibs

 

VMware_bootbank_net-qlge_3.0.0.57-1vmw.550.0.0.1198611
VMware_bootbank_net-qlge_3.0.0.57-1vmw.550.0.0.1198611

 

Right now all hosts are running VMware ESXi, 6.7.0, 17167734.

 

0 Kudos
2 Replies
Arvind_Kumar11
Enthusiast
Enthusiast

Hi Mate,

You might need to remove the impacted VIBs from the host.

I faced same issue during vsphere 7 upgrade and recorded the fix for this issue.

Please try below link if this helps:

https://saystechworld.blogspot.com/2021/01/vmware-vsphere-esxi-upgrade-software-or.html 

 

 

0 Kudos
berndweyand
Expert
Expert

looks like the hosts were upgraded from 5.5 ?

before removal you should check if the drivers are not in use. but drivers from 5.5 should not be in use on a 6.7 host

0 Kudos