VMware Cloud Community
fallentree
Contributor
Contributor

ESXi5 will hang if one of the iscsi connection gone missing

Hi,

I have my esxi5 configured with 3 iscsi connections (3 different storage device), each connection have 2 path, It all wroks fine as usual.

The problem is, one day, one of my storage device is completely dead (ip not reachable) and the dead iscsi is not handled gracefully on esxi, all of my esxi5 nodes starts hang due to lost connection to that device, despite that the other two are functioning correctly.

This cause a huge problem because it renders entire server hang and have to be fixed by cold reboot. vmkernel is filled with logs that saying constantly trying fast path update.

I tried following on the problmatic host and it didn't work:

1) esxcli storage mpath -s off --path

"device is busy"

2) force iscsi rescan, didn't work

3) esxcli storage unmount , still can't unmount that stoarge device

4) restart stoargeRM service, that didn't fix it too

Please help!

0 Kudos
3 Replies
chriswahl
Virtuoso
Virtuoso

Have you installed VMware ESXi 5.0 Patch ESXi500-201111401-BG?

http://kb.vmware.com/kb/2008018

It fixes some iSCSI issues.

VCDX #104 (DCV, NV) ஃ WahlNetwork.com ஃ @ChrisWahl ஃ Author, Networking for VMware Administrators
0 Kudos
fallentree
Contributor
Contributor

That patch was installed, but it didn't solve that problem, in fact, it doesn't seem to solve what it descrbied as well, I am still experencing long boot time.

0 Kudos
AndreTheGiant
Immortal
Immortal

Have you tried to remove the targets in the iSCSI initiator?

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos