rpcblast
Contributor
Contributor

ESXi4 U1 installable usb boot problem

I am trying to get ESXI4U1 to work via USB on a dual opty system, and I cannot seem to get this to work. It does work if I install it to a hard drive hanging off the onboard SAS/SATA raid controller. However, when i attempt to install to a USB drive, the installer does not recognzie the USB disk(flash drive). I Attempted creating the bootable flash drive in vmware workstation, which succeeded. However, when I attempt to boot on my new system, it gets part of the way, then after "loading vfat",. i get an error: failed to find boot partition.

The system is the following:

Asus KFSN4-DRE/SAS running 1012 bios(which was tricky to find)

CPUs: 2 x opteron 2214 HE(will likely put my quads in once i get this working)

memory: kingston DDR2 4 x 4gb

It does work with the local hard drive, so I dont hink I ahve a cpu or NIC issue here.

0 Kudos
8 Replies
continuum
Immortal
Immortal

can you boot the stick on a different machine ?

Can you boot that usbstick inside Workstation (with Plop-bootmanager of course)

Did you check BIOS settings ? - sometimes you can change wether the USBwill be regarded as floppy - disk or zip device ?

You may also try to boot from USB-disk instead of a stick ...




___________________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
golddiggie
Champion
Champion

Does the bios of the mobo support booting from USB flash drives? If there's a setting for the type of USB device, make sure it's set to mimic an actual hard drive (I've seen this on some systems). Which method have you used to install ESXi 4u1 onto the USB flash drive? I've successfully installed ESXi 4u1 onto an USB flash drive using information from here... Using the "Install ESXi to a USB device directly from the install CD" method (NOT the DD method)...

What size USB flash drive did you use? I used a 2GB device. I wouldn't recommend going below that (I have heard of people installing onto 1GB drives). 4GB should be fine too, not sure if I would go to an 8GB flash drive.

Your mobo might just not support booting up from an USB flash drive (unless it's made to mimic an actual drive, which could be another bios setting)... Are you using the USB ports on the back of the mobo, or via headers to the case?

I have to ask why you went to bios 1012 when asus only lists up to 1010... It's not always a good idea to update the bios, unless you're encountering actual issues that are resolved with that update.

VMware VCP4

Consider awarding points for "helpful" and/or "correct" answers.

Hosted Systems Engineer IV (VMware environment)
Brewing beer again!
0 Kudos
rpcblast
Contributor
Contributor

First, thanks for your reponses both. Here is some more information

I know for a fact the board supports booting to USB: thats how I updated the bios was a bootable USB stick with a freedos install.

There is an option in the BIOS to force USB type to HDD, which did not seem to help. The funny thing is, it actually gets part of the way through booting, but errors out after loading VFAT. When I attempt to just redo the install(by hooking up a CD drive and installing directly to the USB), the installer does not find the USB stick, and I have done this using two USB sticks. The USB sticks are crucial gizmo 4gb. The original was created using vmware workstation 7 and direct USB passthrough(the same way as mentioned above, booting to the ISO and picking install to the 4gb USB drive).

I went to 1012 because I could not download 1010, and 1009 broke quad core support(2358s). Actually, the earlier bios, which im guessng was 1000 or 1001, would boot with the quads, but vmware would not load(unsupported microcode). 1009 would not even post with the quads. with 1012, cpu support seems to have been resolved. I got 1012 by picking the KFSN4-DRE/SAS/IKVM instead of just /SAS. These USB problems seem to have not changed through the different bios versions. I was also able to load the installer onto a USB stick and boot from that, and it loaded the isntaller, but again could not see the USB flash drive(could not find a writable location). I did make sure one of the NICs was hooked up as I have had this cause the installer to fail before.

0 Kudos
continuum
Immortal
Immortal

did you try to use a USB-stick that has been created from the dd-image inside the ESXi setup CD ?




___________________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
rpcblast
Contributor
Contributor

not yet, but i think something is up beyond just a bad install on the USB stick, because the installer should recognize the USB stick when I attempt to reinstall.

0 Kudos
continuum
Immortal
Immortal

I don't see a reason to try to install to USB-stick ...






___________________________________

VMX-parameters- WS FAQ -[ MOAcd|http://sanbarrow.com/moa241.html] - VMDK-Handbook

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
rpcblast
Contributor
Contributor

in case there was a bad install I was going to try to create a new one...

0 Kudos
jonf805
Contributor
Contributor

I have the same issue. Did you end up resolving this? It definately seems to be an incompatibility between ESXi and the KFSN4. The USB sticks I created by extracting the DD image work on other hardware (Supermicro server) but has issues with the Asus KFSN4.

Xenserver has no such issues and supports both the LSI SAS raid and the Nvidia Raid. I wish VMWare would support more common hardware.

0 Kudos