oeribon
Contributor
Contributor

ESXi upgrade from 7.0 update 3 to 8.0

All,
I try to upgrade from cli my new ESXi (PowerEdge R650 SmartValue Bundle[512Go RAM]) delivered with 7.0 Update 3 (demo) to 8.0.
 
[root@stedl-esx-serv-7:~] esxcli network firewall ruleset set -e true -r httpClient
[root@stedl-esx-serv-7:~] esxcli software profile update -d http://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vm
w-depot-index.xml -p ESXi-8.0.0-20513097-standard
 [DependencyError]
 On platform embeddedEsx, VIB DEL_bootbank_dellemc-fac-dcui_7.0.3-A00 requires esx-version << 7.1, but the requirement cannot be satisfied within the ImageProfile.
 Please refer to the log file for more details.
 
[root@stedl-esx-serv-7:~] cat /var/run/log/esxcli.log  
2022-11-29T12:19:09Z esxcli: ERROR [2102782] update failed:  [DependencyError]  On platform embeddedEsx, VIB DEL_bootban
k_dellemc-fac-dcui_7.0.3-A00 requires esx-version << 7.1, but the requirement cannot be satisfied within the ImageProfil
e.  Please refer to the log file for more details.

Before I try to create a USB stick from VMware-VMvisor-Installer-8.0-20513097.x86_64.iso and plug it in front of the server. Reboot and select F11 and USB but the running version after that was always the 7.0.3 (and not 8.0 live as expected) and no way to do an upgrade (or an install).
 
Please, could you help me.
Olivier
0 Kudos
5 Replies
Kinnison
Expert
Expert

Hi,


Sorry, your server came pre-installed with the trial version (which is not a "demo") of the ESXi version 7.0U3 customized by DELL, but you want to update it with the standard version (let's say the "generic" non OEM specific version). In my opinion, you would do it sooner and save yourself possible problems by using the corresponding DELL customized image for ESXi product version 8 which you can download via the "VMware customer connect" (usually the recommended approach, unless there are specific reasons).


Regards,
Ferdinando

0 Kudos
maksym007
Hot Shot
Hot Shot

Why not to try with iDRAC and simply attach ISO there? 

0 Kudos
oeribon
Contributor
Contributor

Thanks for your comment,

iDRAC is probably not configured (I need to give a look on it). My problem seems to be linked with DellEMC Customized version of VMware ESXi Image. I need to found a new image for 8.0 version. I asked to the Dell support but no answer.

Thanks again

 

0 Kudos
oeribon
Contributor
Contributor

Hi,

Thank you for your explanation. You are totally right. But it seems there is no custom DELL ESXi 8.0 image yet.
I'll wait for Dell's response.

Actually, I'm using a 7.0 trial version (completed in a few days) and I have a real 8.0 license that I can't use.

Regards,

Olivier

0 Kudos
Kinnison
Expert
Expert

0 Kudos