lvaibhavt
Hot Shot
Hot Shot

ESXi shell works after being disabled

Jump to solution

Hi All,

I have an esxi 5.5 in my home lab and esxi shell was disabled on it. I tried alt + f1 but it will not give me the login prompt. (this is a known behavior)

I enabled esxi shell and it gave me a prompt to enter username and password. I entered the credentials and then I was able to access the shell locally from the esxi server. Now the question is once I have disabled the esxi shell -- if I hit alt + f1 then also it lets work on it.

I am unable to understand if the esxi shell is disabled (previously it was enabled) then why it will let me work on the DCUI console? any suggestions

Thanks

Vaibhav

0 Kudos
1 Solution

Accepted Solutions
peetz
Leadership
Leadership

Hi Vaibhav,

disabling the local ESXi shell will not terminate a session that is already logged in at the console. It will only prevent new logins.

With remote SSH sessions the behavior is the same: Existing ssh session will continue to run after you disable the SSH shell.

Regards

Andreas

Twitter: @VFrontDe, @ESXiPatches | https://esxi-patches.v-front.de | https://vibsdepot.v-front.de

View solution in original post

0 Kudos
4 Replies
peetz
Leadership
Leadership

Hi Vaibhav,

disabling the local ESXi shell will not terminate a session that is already logged in at the console. It will only prevent new logins.

With remote SSH sessions the behavior is the same: Existing ssh session will continue to run after you disable the SSH shell.

Regards

Andreas

Twitter: @VFrontDe, @ESXiPatches | https://esxi-patches.v-front.de | https://vibsdepot.v-front.de
0 Kudos
nash097
Enthusiast
Enthusiast

Did you close the existing session and re open it after you disabled the ESXi shell? Does it still work?

0 Kudos
Nithy07cs055
Hot Shot
Hot Shot

this is because the  session which you used to disable the shell might not have been disconnected, make sure you come out of the DCUI and login back , you wont get the shell prompt 

Thanks and Regards, Nithyanathan R Please follow my page and Blog for more updates. Blog : https://communities.vmware.com/blogs/Nithyanathan Twitter @Nithy55 Facebook Vmware page : https://www.facebook.com/Virtualizationworld
0 Kudos
lvaibhavt
Hot Shot
Hot Shot

Hi All,

Thank you all for replying I had to type exit on the command line in shell. Then when it was disabled then it did not allowed to me logon again.

Thanks again

Vaibhav

0 Kudos