cgluser
Contributor
Contributor

ESXi hostd and hostd-probe logging level

Hi All,

I need to set all log in my esxi as "info" instead of "verbose".

From vSphere Web Client I set to "info" in Advanced Settings all HostAgent.level and vpxa.config.log.level

After doing that I still see verbose messages in hostd.log and hostd-probe,log

What am I doing wrong? How can i stop this messages?

Thanks

Ale

PS: yes, i know that the best practices say that is better to keep logging level untouched, but i need to change.

0 Kudos
5 Replies
jatinjsk
Enthusiast
Enthusiast

For Hostd, Please goto etc/vmware/hostd/config.xml and check the log level defined there. If desired log level is not set then you can edit config.xml and edit the log level as desired.

# cd etc/vmware/hostd/

# cat config.xml  |grep log

<logLevel>warning</logLevel>

<logName>ActiveDirectoryAuthentication</logName>

    <logLevel/>

    <logName>Hbrsvc</logName>

    <logLevel/>

    <logName>Hostsvc</logName>

   <logLevel>info</logLevel>

<logName>PropertyProvider</logName>

    <logLevel/>

    <logName>Proxysvc</logName>

    <logLevel/>

    <logName>Snmpsvc</logName>

    <logLevel>info</logLevel>

<logName>SoapAdapter.HTTPService</logName>

    <logLevel/>

    <logName>Statssvc</logName>

    <logLevel/>

    <logName>Vcsvc</logName>

    <logLevel/>

    <logName>Vimsvc</logName>

    <logLevel/>

    <logName>Vmsvc</logName>

  <log>

<directory>/var/log/vmware/</directory>

<outputToSyslog>true</outputToSyslog>

    <syslog>

<logHeaderFile>/var/run/vmware/hostdLogHeader.txt</logHeaderFile>

    </syslog>

  </log>

<arg id="2">/usr/bin/python -m PyVmomiServer -g --loglevel info -s PyVmomiServer</arg>

      <loglevels>

      </loglevels>

  <workingDir>/var/log/vmware/</workingDir>

Hope this is helpful.

0 Kudos
cgluser
Contributor
Contributor

Thanks, I think that my situation is already as you wrote

[root@esx09:/etc/vmware/hostd]

[root@esx09:/etc/vmware/hostd] cat config.xml  |grep log

    <logLevel>warning</logLevel>

    <logName>ActiveDirectoryAuthentication</logName>

    <logLevel>info</logLevel>

    <logName>Hbrsvc</logName>

    <logLevel>info</logLevel>

    <logName>Hostsvc</logName>

    <logLevel>info</logLevel>

    <logName>Proxysvc</logName>

    <logLevel>info</logLevel>

    <logName>Snmpsvc</logName>

    <logLevel>info</logLevel>

    <logName>Statssvc</logName>

    <logLevel>info</logLevel>

    <logName>Vcsvc</logName>

    <logName>Vigor</logName>

    <logLevel>info</logLevel>

    <logName>Vimsvc</logName>

    <logLevel>info</logLevel>

    <logName>Vmsvc</logName>

  <log>

    <directory>/var/log/vmware/</directory>

    <outputToSyslog>true</outputToSyslog>

    <syslog>

      <logHeaderFile>/var/run/vmware/hostdLogHeader.txt</logHeaderFile>

    </syslog>

  </log>

            <arg id="2">/usr/bin/python -m PyVmomiServer -g --loglevel info -s PyVmomiServer</arg>

      <loglevels>

      </loglevels>

  <workingDir>/var/log/vmware/</workingDir>

But when I look into hostd.log i find this:

cat /var/log/hostd.log | grep verbose

...

2017-11-14T15:09:35.524Z verbose hostd[32980B70] [Originator@6876 sub=Solo.Vmomi opID=dceedbd7 user=root] Arg version:

2017-11-14T15:09:35.524Z verbose hostd[32980B70] [Originator@6876 sub=Solo.Vmomi opID=dceedbd7 user=root] Arg options:

2017-11-14T15:14:35.533Z verbose hostd[32980B70] [Originator@6876 sub=Solo.Vmomi opID=dceedc65 user=root] Arg version:

2017-11-14T15:14:35.533Z verbose hostd[32980B70] [Originator@6876 sub=Solo.Vmomi opID=dceedc65 user=root] Arg options:

2017-11-14T15:19:35.541Z verbose hostd[32740B70] [Originator@6876 sub=Solo.Vmomi opID=dceedcec user=root] Arg version:

2017-11-14T15:19:35.541Z verbose hostd[32740B70] [Originator@6876 sub=Solo.Vmomi opID=dceedcec user=root] Arg options:

2017-11-14T15:24:35.550Z verbose hostd[32740B70] [Originator@6876 sub=Solo.Vmomi opID=dceedd7c user=root] Arg version:

2017-11-14T15:24:35.550Z verbose hostd[32740B70] [Originator@6876 sub=Solo.Vmomi opID=dceedd7c user=root] Arg options:

2017-11-14T15:29:35.559Z verbose hostd[33940B70] [Originator@6876 sub=Solo.Vmomi opID=dceede0e user=root] Arg version:

2017-11-14T15:29:35.559Z verbose hostd[33940B70] [Originator@6876 sub=Solo.Vmomi opID=dceede0e user=root] Arg options:

Any Ideas?

0 Kudos
cgluser
Contributor
Contributor

Any Ideas?

Do I need to reload some services in order to apply changes?

Is there any other reason why this verbose messages are still logged?

Thanks

Ale

0 Kudos
jatinjsk
Enthusiast
Enthusiast

Yes You need to restart below service

cd /etc/init.d

./mgmt-vmware restart

To change the log level in config.xml for hostd on an ESX system

1

Connect to the ESX system using putty or an other secure shell.

2

Open the config.xml file located at /etc/vmware/hostd

3

Change <level>info</level> to <level>trivia</level>, and save and close the file.

4

Navigate to the init.d directory and restart the host agent.

cd /etc/init.d

./mgmt-vmware restart

After the service restarts, the new log level is in effect.

Ref: vSphere Documentation Center

Hope this will solve your issue. I will try this in my lab and will share the results with you as well.

GalNeb
Enthusiast
Enthusiast

I see that this thread is nearly a year old, but I can not find a solution and I have the same issue.  I am getting as many as 400 verbose hostd messages a minute even though I have set all logging levels to info.  As the op has done, I have set all the advanced settings to info.  I have checked the /etc/vmware/hostd/config.xml file and it is clean.

In addition, I manually changed the /etc/opt/vmware/fdm/fdm.cfg file to info which eliminated quite a few messages and even seemed to have some impact on the number of hostd messages (don't ask me why).  I also manually changed the /etc/vmware/rhttpproxy/config.xml file to info which eliminated another good 100 messages a minute.  I am only getting 1 verbose message every 5 minutes from hostd-probe so I am not worried about it.

With 48 hosts in this particular datacenter, 1 of 4 that I work with, 400 a minute amounts to over 1/2 Million messages a day going to Log Insight and then on to Splunk.  This is creating quite a load on both of these systems to process what amounts to junk messages.

Oh, I am running 6.5 u1 with all patches.  I am still waiting for NetApp to get off their ass and release their plugins for 6.7 before we upgrade further.

If anyone has found a solution to this problem, please post.

Old enough to know better, young enough to try anyway
0 Kudos