thomasnagel
Contributor
Contributor

ESXi host with public IP - GUI should be accessible from internal vswitch/portgroup with local ip

Jump to solution

We have an ESXi Host with a public (but separately firewalled) IP address.

All hosts have to have private IPs in the range of 10.13.31.1-254.

So we have added a second virtual switch "localnetwork" for this local network and a port group named "localnetwork".

Since we have a backup instance running on one of these virtual machines we would rather access the ESXi Host via a private IP Adress. Since the Mangemant network ist bound to the physical switch, we thought it would be best to create a second VMkernel NIC and connect this to the "localnet" portgroup and use an IP like 10.13.31.5 for this, and activate "Mangement" under "Services" in "Add VMkernel NIC".

This actually works now, as the mangement GUI is accessible under the new IP, and the public IP.

BUT: When this is active, I can no longer select the "localnet" in each VM's network configuration - only the default "VM Network" is shown. If a reboot am VM, connection to this network is disconnected and cannot be connected since the drop down menu only shows the old "VM Network", not the specially created one.

Even if I do not check the "Mangement" under "Services" when creating the vmk1 - I then can no langer select this network for a VM.

Is this a bug, or what is the conception of this behaviour?

How can I achieve what I was originally planning: Having access to the GUI vom an internal IP Range?

Thanks - any help is much appreciated.

0 Kudos
2 Solutions

Accepted Solutions
aakalan
Enthusiast
Enthusiast

Can you create a new portgroup with the same configuration with localnet and do not assign it to vmkernel. after that select this new network.

View solution in original post

0 Kudos
thomasnagel
Contributor
Contributor

I am not sure, if I got right, what you were suggesting, maybe actually I think you just made another order with your solution - i now did:

- had localnet, removed the old vmk1 that was making problems

- added a portgroup "vmk-intermed", added this to the vswitch of "localnet"

- added vmk1 to "vmk-intermed" with "Management" Option.

Now I have access to the Mangament Interface, but still can select my original localnet vor my vms.

Was easier in this order, since I didn't want to change all networks on all vms.

Thanks! You got me in the right direction.

View solution in original post

0 Kudos
2 Replies
aakalan
Enthusiast
Enthusiast

Can you create a new portgroup with the same configuration with localnet and do not assign it to vmkernel. after that select this new network.

0 Kudos
thomasnagel
Contributor
Contributor

I am not sure, if I got right, what you were suggesting, maybe actually I think you just made another order with your solution - i now did:

- had localnet, removed the old vmk1 that was making problems

- added a portgroup "vmk-intermed", added this to the vswitch of "localnet"

- added vmk1 to "vmk-intermed" with "Management" Option.

Now I have access to the Mangament Interface, but still can select my original localnet vor my vms.

Was easier in this order, since I didn't want to change all networks on all vms.

Thanks! You got me in the right direction.

0 Kudos