VMware Cloud Community
fcarballo
Contributor
Contributor
Jump to solution

ESXi and multipath

Hello friends!

If I have two vmk interfaces, each one in a different NIC but on the same subnet, and I send a vmkping to a IP on that subnet.

Wich interface will ESXi use to reach the destination? Can I force the vmkping (or similar) to use a specific vmk port?

What I want to do is test if my ESXi host is properly reaching my storages. I can reach my storage over my two fisical paths (NICs), but just over one NIC I can ping and get a response.

To be more specific about my enviroment:

vmk1 -> NIC A -> 192.168.130.200

vmk2 -> NIC B -> 192.168.130.201

vmkping 192.168.130.103 (NIC A or NIC B? Wich one will be used to reach that IP. Can I force one or other?)

Best regards!

Felipe Carballo - VCP5 - VCP-Cloud
Reply
0 Kudos
1 Solution

Accepted Solutions
Andy_Banta
Hot Shot
Hot Shot
Jump to solution

> You can use -I option to specify the outgoing interface IP.

Actually the -I option is only good with IPv6.  It doesn't do anything with IPv4.

The vmkernel network stack will choose the first entry in its route table that can reach the destination.  In this case, it would probably be the first vmkNIC.

Andy

View solution in original post

Reply
0 Kudos
8 Replies
AndreTheGiant
Immortal
Immortal
Jump to solution

You can use -I option to specify the outgoing interface IP.

PS: remember that you must use esxcli to add both vmkernel interface to iSCSI adapter.

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
Reply
0 Kudos
bulletprooffool
Champion
Champion
Jump to solution

Are you providing 2 pNics for failover / redundancy?

If so - I'd add both pNics to the same vSwitch and create my vmkernel port on this - with 1 IP and a load balancing policy set to whatever your preference is.

You can then test your NICs simply by reversing the policy, or removing 1 pNic from the vSwitch and testing, then re-adding and removing the other to test.

One day I will virtualise myself . . .
Reply
0 Kudos
fcarballo
Contributor
Contributor
Jump to solution

Actually, I'm configuring my server to access my SAN.

On my host I reserved two NICs to connect to the SAN.

NIC A IPs (each one a vmk port)

192.168.xxx.200 (xxx = 130-133)

NIC B IPs  (each one a vmk port)

192.168.xxx.201 (xxx = 130-133)

NIC A is connected to Switch A and NIC B is connected to Switch B.

My storage is a DELL MD3200i, with 8 NICs. The NICs of storages's controller 0 is connected at switch A and the NICs of storage's controller 1 is connected at switch B.

If I send a ping to any IP at controller 1, it doesn't response. However, my host is reaching the storage over both controllers.

I don't know the reason for this behavior.

Felipe Carballo - VCP5 - VCP-Cloud
Reply
0 Kudos
AndreTheGiant
Immortal
Immortal
Jump to solution

You can put 130 and 131 network on switch A and 132 and 133 on switch B.

This schema is suggested from Dell configuration.

PS: check on Dell site the last document about vSphere 4.1... there are some specific configuration to make.

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
fcarballo
Contributor
Contributor
Jump to solution

Andre,

I'll check the documentantion on DELL's site.

Even not getting a ping response from 192.168.xxx.104 (storage's controller 1), I still able to reach it. That behavior that I cannot understand.

I can reach both controllers, but I can only ping to IPs at storage's controller 0. o.O

Felipe Carballo - VCP5 - VCP-Cloud
Reply
0 Kudos
AndreTheGiant
Immortal
Immortal
Jump to solution

Have you try to use a PC and a VM  to test if is a network problem?

Andre

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
Reply
0 Kudos
Andy_Banta
Hot Shot
Hot Shot
Jump to solution

> You can use -I option to specify the outgoing interface IP.

Actually the -I option is only good with IPv6.  It doesn't do anything with IPv4.

The vmkernel network stack will choose the first entry in its route table that can reach the destination.  In this case, it would probably be the first vmkNIC.

Andy

Reply
0 Kudos
fcarballo
Contributor
Contributor
Jump to solution

Andy, thank you so much for your reply.

You confirmed what I thought. It's the normal behavior.

Best regards.

Felipe Carballo - VCP5 - VCP-Cloud
Reply
0 Kudos