mdaniel2
Contributor
Contributor

ESXi Host disconnects from vcenter

Jump to solution

Hi,

I have an ESXi added ti the vcenter inventory and the host disconnects from vcenter server after aprox 60 seconds, reporting the host state as Disconnected.

Any idea?

 

Thx

0 Kudos
1 Solution

Accepted Solutions
ubecerro
Contributor
Contributor

Hi mdaniel2!,

A possible cause is a port blocked by firewall.  The ESXi host sends heartbeats every 10 seconds to vCenter Server. By default, this traffic is sent over UDP port 902. vCenter Server has a window of 60 seconds to receive the heartbeats. If the heartbeat is not received in 60 seconds, vCenter Server considers that the host is not responding.
A problem might occur if the host is configured to send heartbeats over a port other than 902. At the ESXi host command prompt, you enter the less /etc/vmware/vpxa/vpxa.cfg command to determine the port in use. The port number in use is contained in the serverPort tags

ubecerro_0-1607024525975.png


For more information about how to troubleshoot an ESXi host that disconnects from vCenter Server after being added or connected to the inventory, see VMware KB article 2040630 at http://kb.vmware.com/kb/2040630


For information about the ports required for communications between vSphere components, see https://ports.vmware.com/

Regards,

Ulises

View solution in original post

1 Reply
ubecerro
Contributor
Contributor

Hi mdaniel2!,

A possible cause is a port blocked by firewall.  The ESXi host sends heartbeats every 10 seconds to vCenter Server. By default, this traffic is sent over UDP port 902. vCenter Server has a window of 60 seconds to receive the heartbeats. If the heartbeat is not received in 60 seconds, vCenter Server considers that the host is not responding.
A problem might occur if the host is configured to send heartbeats over a port other than 902. At the ESXi host command prompt, you enter the less /etc/vmware/vpxa/vpxa.cfg command to determine the port in use. The port number in use is contained in the serverPort tags

ubecerro_0-1607024525975.png


For more information about how to troubleshoot an ESXi host that disconnects from vCenter Server after being added or connected to the inventory, see VMware KB article 2040630 at http://kb.vmware.com/kb/2040630


For information about the ports required for communications between vSphere components, see https://ports.vmware.com/

Regards,

Ulises

View solution in original post