Bognad
Contributor
Contributor

ESXi/ESX host disconnects from vCenter Server after power up VM: "An error occured while communicating with remote host"

Jump to solution

I encontered an strange error, when  i try to power on a VM (or change VM configuration)  through a vCenter the error message appears :An error occured while communicating with remote host

ESXi host disconnect immediately (5-10 sec)  after clicking PowerOn button. All VMs are work fine, only ESXi host disconnect from vCenter.

I try change config.vpxd.heartbeat.notrespondingtimeout=120.   

VMware Knowledge Base

But the problem still remains.

I had the same happen in vSphere 5.5 and 6.5.

I have meet this error every power up VM.

The vpxd.log is empty.

0 Kudos
1 Solution

Accepted Solutions
Bognad
Contributor
Contributor

ESXi configuration file config.xml had some syntax error.

View solution in original post

0 Kudos
5 Replies
msripada
Virtuoso
Virtuoso

If it is happening to disconnect  the ESXi hosts for 5.5 and 6.5, then I would strongly advise to check the port 902 UDP if it is open between ESXi and vCenter. port 902 UDP is used for heartbeat. If the heartbeat is missed or not received within the time (Default of 60 seconds, which you changed to 120 with the advanced parameter), the ESXi will be marked not responding.

VMware Knowledge Base

- MS

0 Kudos
Bognad
Contributor
Contributor

Tankyou msripada !

ESXi host disconnect immediately (msx 5-10 sec, not 60, not 120 sec)  after clicking PowerOn button.

I have several  ESXi server, but problem only at one - 172.16.37.179.

172.16.37.179   ESXi 6.5  disconnect  when VM Power UP.

172.16.37.100  ESXi 5.5   work fine

172.16.37.127  ESXi 5.5   work fine

172.16.37.177  ESXi 5.5  work fine

172.16.37.179   ESXi 6.5 work fine

172.16.37.210   ESXi 6.5 work fine

172.16.37.209    vCenter 6.5

Result  nmap -sU -sV -p 904 -PU 172.16.37.XXX :

172.16.37.179   ESXi 6.5  disconnect 

PORT    STATE  SERVICE

904/udp open|filtered unknown

172.16.37.100  ESXi 5.5   work fine

PORT    STATE  SERVICE

904/udp closed unknown

172.16.37.127  ESXi 5.5   work fine

PORT    STATE         SERVICE

904/udp open|filtered unknown

172.16.37.177  ESXi 5.5  work fine

PORT    STATE  SERVICE

904/udp closed unknown

172.16.37.210   ESXi 6.5 work fine

PORT    STATE         SERVICE

904/udp open|filtered unknown

172.16.37.209    vCenter 6.5

PORT    STATE         SERVICE

904/udp open|filtered unknown

0 Kudos
rajen450m
Hot Shot
Hot Shot

Hi,

Please follow the below steps and check.

=> Power ON ESXi and navigate to advanced settings and change the below tow:

  • “numa.autosize.once = False”
  • “Numa.FollowCoresPerSocket = 1”

Regards,

Raj M Please mark helpful or correct if my answer resolved your issue. Visit www.hypervmwarecloud.com for my blog posts, step-by-step procedures etc.,
0 Kudos
Bognad
Contributor
Contributor

Thankyou!

vnuma and reconnect

sorry how is that related?

0 Kudos
Bognad
Contributor
Contributor

ESXi configuration file config.xml had some syntax error.

View solution in original post

0 Kudos