bigideaguys
Contributor
Contributor

ESXi 7U3 DNS Suffix issue - won't change

Has anybody ever come across the issue where when doing an initial configuration of ESXi, it pulls in your router suffix and refuses to replace it with one you intentionally add in the admin?

I installed Workstation Pro 16 on my PC. This PC is connected to my internal domain home.buttitta.net

Then installed the latest ESXi 7U3. It installed with no issue, and I booted into it.

I configured the Management network IP addresses of ESXi to static (192.168.1.220, subnet mask 255.255.255.0 and default gateway 192.168.1.1 which is my router)

I configured the DNS addresses of ESXi to static, and the IP's to my 2 internal domain controllers (2 small HP PC’s with Windows Server 2022 Standard) 192.168.1.202, 192.168.1.203

I configured the Hostname to ESXi7-1 and manually registered it in my DNS settings in my Domain Controllers.

I configured this to use bridged networking and other PC’s on my network can go to 192.168.1.220 and access the admin page.

But no matter what I do, it pulls in hsd1.ca.comcast.net as the domain suffix and I can NOT get it to go away. If I add my domain suffix it adds it at the end after this. It SHOULD replace it. When logging in to the Web admin it shows the ESXi machine to be named
ESXi7-1.hsd1.ca.comcast.net

I have even tried following guides that show how to do it from the command line via a shell and no luck.

This is driving me crazy because everything I have Googled shows that just changing it in the management part in ESXi SHOULD work.

I am at my wits end for help to understand what is going on and how to fix this.

5 Replies
a_p_
Leadership
Leadership

What should work is to enter the hostname in the ESXi host's DNS settings in the DCUI as a fully qualified host name (e.g. youresxi.yourdomain.net). After that, check the DNS suffixes in the search list, and adjust them as well if needed.

André

bigideaguys
Contributor
Contributor

Thank you André! That was such an easy solution! I guess when it first installed and it's pulling DNS from the router, it uses the ISP DNS.

So plugging in the FQDN in the Hostname data input and then adjusting the Suffix to remove the Comcast one stuck after the network reset.

However, I have set up ESXi many times previously and I have never seen this behavior before. For one, I couldn't find any support articles detailing this or anything via Google, and I would think if this is expected behavior, the solution would be documented somewhere?

The verbiage for that data input is Hostname, no mention of FQDN. And given there is a place to plug in Suffix, the logical conclusion is by inputting these values in the DCUI, it would then force it to override any dynamic data pulled in during install. It all makes perfect sense once explained and you see what it does, just suggesting VMWare could do a better job of documenting this and maybe tweaking verbiage in the DCUI, like Hostname (with FQDN) instead of just Hostname. Just a thought, because once it over rides the values and "fixes" itself, it goes back to only the Hostname shown in the Hostname fields and only the Suffix in the Suffix section. It almost seems like a bug?

a_p_
Leadership
Leadership

That's an interesting point. After reading your reply, I did a quick search in the current documentation, but couldn't find a hint regarding the FQDN either.

Anyway, another place where this can be modified is from the ESXi host's web client ...
Networking >> TCP/IP stacks >> Default TCP/IP stack >> Edit Settings

... or the command line
esxcli system hostname set --host=hostname
esxcli system hostname set --fqdn=fqdn

That said, I'm not sure whether the two above mentioned options will also trigger a certificate re-generation, as with the DCUI option.

André

Sitz
Contributor
Contributor

Hi @bigideaguys 

same for me even nine months after your experience.

Thanks for posting.

0 Kudos
Sitz
Contributor
Contributor

Hi @a_p_ 

your solution works fine for me, from the console to the Web client.

Thank you very much for your support.

 

0 Kudos