ESXi 7.0.2 settings are not persistent after reboot

Hi everyone, as the title says my settings are not persistent, all my VMs and datastores disappear, and my license is no longer applied every time I reboot. I think I have narrowed down the issue to having ESXi installed on a USB and have found this article

I also found this post but was unable to actually save the boot.cfg (

- I have tried editing boot.cfg via ssh but it's not in the /bootbank/ directory
- I tried editing the settings via the UI but they are not persistent after reboot
- I have tried holding Shift+O during startup and entering (kernelopt=autoPartition=TRUE skipPartitioningSsds=TRUE autoPartitionCreateUSBCoreDumpPartition=TRUE allowCoreDumpOnUsb=TRUE) the settings were not applied when I looked at them in the UI
- I have also plugged the USB into a windows machine and edited the boot.cfg (this is what it looks like but still have the same issue

I'm totally stuck here, does anyone have some insight?

0 Kudos
0 Replies