MohammedQuadri
Contributor
Contributor

ESXi 7.0.0 (VMKernel Release Build 16324942) is not remembering saved network settings

After reboot, shutdown, power-off/on, we noticed sometimes ESXi doesn't remember the network adapter settings we configured it as.

It reverts back to static IP with some of network adapters "disabled". 

We have configured it to use all network adapters and use DHCP and dynamically acquire IP.

Verified BIOS settings to be correct.

Any explanation or help is appreciated.

 

We assumed that once we save the settings they will be preserved across reboot/power down/up sequence.

 

Thanks!

0 Kudos
5 Replies
a_p_
Leadership
Leadership

I've seen such issues myself too with some of the first ESXi 7.0 builds. Not sure, but I assume that these issues were caused by the migration to another way they store the settings (esx.conf -> configstore).

In this case I'd suggest that you update/patch your host (if possible) to the current build.

André

0 Kudos
scott28tt
VMware Employee
VMware Employee

So are you saying your vSwitch, vmnic, and vmk configuration in ESXi changes from boot to boot, or something else?

Your post is going to need moving to another area of the Communities, so I have reported it.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
scott28tt
VMware Employee
VMware Employee

I reported your other post on the same topic: https://communities.vmware.com/t5/Technical-Community-Resources/ESXi-reboot-or-power-up-sequence-fai...

And now I see you created this thread in the correct area anyway, as only one post is needed I'll leave it to moderators to decide which to remove.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
MohammedQuadri
Contributor
Contributor

Thanks!

First time on vmware communities. I couldn't figure out right community to post the question.

Thanks again for letting me know.

ESXi 7.0 Network settings for adapters and Dynamic IP/ HHCP and DNS were not remembered sometimes. We saved them and rebooted and sometimes it comes up with us having to change the settings again. 

Tags (1)
0 Kudos
MohammedQuadri
Contributor
Contributor

Many hanks for sharing this information!

 

Mystery is the behavior is intermittent. Trying to explain the behavior if it was storage then I would see same behavior consistently?

 

Trying to chase the root cause of the problem, we experimented many things including careful analysis of BIOS settings. Couldn't find the reason but for strange reason it has been working fine now! 

We don't want client to experience the same behavior when they reboot or shutdown/restart and loose their network settings. I wonder if ESXi reverts to static IP during firing up if it encounters any issue. This is one thing we haven't yet dived deeper.

Tags (1)
0 Kudos