trailx
Enthusiast
Enthusiast

ESXi 6.5: Passthrough 2 GPUs on a single VM ?

Jump to solution

Hello

I'm trying to passthrough 2 Nvidia P100 on a single VM but I got a black screen and no logs for my VM...

It works with 1 GPU Smiley Happy but can't figure out why it doesn't work with 2 :smileyconfused:

In advance setting of vm, I only added :

pciPassthru.use64bitMMIO="TRUE"

firmware="efi"

Is there a restriction from VMware or NVidia ? or is it a configuration mismatch ?

Thanks

--- If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!
0 Kudos
1 Solution

Accepted Solutions
Blaze4up
Enthusiast
Enthusiast

Hi ,

I did the same thing with 4 K80 cards. Besides the advanced setting you did , there is another one you need to add.:

pciPassthru.64bitMMIOSizeGB = “64″

This blog exsplains it all:

https://octo.vmware.com/enable-compute-accelerators-vsphere-6-5-machine-learning-hpc-workloads/

View solution in original post

0 Kudos
5 Replies
Nick_Andreev
Expert
Expert

Let us know what you trying to achieve. Is it some kind of gaming rig, graphics workstation, or maybe you're trying to use it for VDI? Some people may offer a workaround once they know more.

---
If you found my answers helpful please consider marking them as helpful or correct.
VCIX-DCV, VCIX-NV, VCAP-CMA | vExpert '16, '17, '18
Blog: http://niktips.wordpress.com | Twitter: @nick_andreev_au
0 Kudos
Blaze4up
Enthusiast
Enthusiast

Hi ,

I did the same thing with 4 K80 cards. Besides the advanced setting you did , there is another one you need to add.:

pciPassthru.64bitMMIOSizeGB = “64″

This blog exsplains it all:

https://octo.vmware.com/enable-compute-accelerators-vsphere-6-5-machine-learning-hpc-workloads/

View solution in original post

0 Kudos
trailx
Enthusiast
Enthusiast

Sorry, I don't know why I didn't receive notification. I found this blog too which explained why I had to map more than 32GB.

Thanks

--- If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!
0 Kudos
Baefisch
Contributor
Contributor

i am not able to see the card on my virtual machine windows 10.
i exactly followed the blog.

Can anybody help me?

This is my config:

pciPassthru.use64bitMMIO="TRUE"

pciPassthru.64bitMMIOSizeGB = "32"

pciPassthru0.id = "00000:010:00.0"

pciPassthru0.deviceId = "0x15f8"

pciPassthru0.vendorId = "0x10de"

pciPassthru0.systemId = "576cdd74-0d85-0676-65b7-0025b50002ab"

pciPassthru0.present = "TRUE"

pciPassthru0.pciSlotNumber = "192"

Is it correct, that i do not have to install any driver?

0 Kudos
JoshSimons
VMware Employee
VMware Employee

Did you create your VM to use UEFI booting? That is a requirement.

If you did and you are still having problems passing the card into your VM, please send the vmware.log file to simons at vmware.com and I will take a look.

0 Kudos