ESXi 6.5 Failing to upload/deploy OVA files postNFCData failed error

I've been tasked with testing out multiple SSL VPN solutions for our company. Naturally before putting it into our dev or production servers I wanted create a test environment with two desktops to try out different SSL VPN trials.

Client: Version 1.23.0 (Build 6360286)

Host:Version 6.5.0 (Build 6765664)

I deployed F5-BIG-IP's OVA (1.36GB) perfectly fine and could experiment around with the software. Next I went to try out Array Network's vxAG (2.40GB) and it failed with different errors, I thought it may just be Array's OVA is corrupt. From there I went out and tried damn small linux to see if it was an OVA problem but the linux client deployed without a hitch. So I went to try to deploy Pulse Secure SSL VPN solution which is an VMDK and OVF file (3.02GB) and that eventually error-ed out just like Array Network's. I tried uploading a large file and that ending up failing (Windows install.esd 2.87GB) so I have a feeling it has something to do with the file sizes.

Here are the multiple different errors:

If I try to create a new virtual machine the OVA it gets to a random percent freezes and eventually gives the 'Result: Failed - Upload disk cancelled' and I get a "Failed to deploy VM: postNFCData failed" error (Note the VMDK file uploads to the datastore but not the OVF or MF)

If I try to just upload the file to the datastore it also gets to the same percent, freezes then after a random amount of time the OVA shows in the datastore, but if you close the datastore page and reopen it the file magically disappears! Meanwhile the 'Upload file to datastore' Task is still hanging at the same percent.

Array Network's vxAG gets to 74-75% then fails

Pulse gets to 60% and fails

The Windows install.esd gets to 60% and fails

Attempted troubleshooting

I've tried Chrome, Firefox, and IE

I've tried ESXi 6.0 and different builds of 6.5

I've patched to the most up-to-date host and client version (Suggested in related discussions:ESXi 6.0 U2 - "Failed to deploy VM: postNFCData failed." - when importing a OVA template via ESXi Ho...)

I've tried messing with certificates and DNS to a degree

Added a licencing key

I really rather not resort to using the ovftool even though I constantly hear how amazing it is.

Does anyone have a fix or other troubleshooting routes I could take? Any help would be much appreciated!

2 Replies

Have you tried both the vSphere Client and HTML5 client?

If none of them work, try ovftool. It's reasonably easy to use.

If you found my answers helpful please consider marking them as helpful or correct.
VCIX-DCV, VCIX-NV, VCAP-CMA | vExpert '16, '17, '18
Blog: http://niktips.wordpress.com | Twitter: @nick_andreev_au

The errors I posted were from using the VMware ESXi web client. When I try to deploy in our dev environment (vCenter) which I've tried both the vSphere flash client and HMTL5 client and both throw completely different errors from what I was getting in my test environment:

Transfer failed: IO error during transfer of 'null': Read timed out.

The operation failed for an undetermined reason. Typically this problem occurs due to certificates that the browser does not trust. If you are using self-signed or custom certificates, open the URL below in a new browser tab and accept the certificate then retry the operation.


If this does not resolve the problem, other possible solutions are shown in this KB article:


The strange thing is all the two host IPs in that server cluster show up at trusted I also checked the DNS name of vCenter (https://***vCenter/ui/) and it's trusted as well. I want to think it's a certificate problem but I don't know to what extent. I'll give the ovf tools another go later today.

EDIT: OVFTools deployed the Array OVA so far so good. Although this shouldn't be the fix for this problem in the long run I hope!