rspoto
Contributor
Contributor

ESXi 6.5.0a Install and WGET

Hi All -

I've been recently working on a number of PXE booted installs of ESX.  I have a kickstart file that has a %post section that performs a few actions, then sends a simple GET request to a web server using wget.  The %post stuff works great in 5.5 Update 3, 6.0 Update 2, and 6.0 Update 3.  When I try it with 6.5.0a (4887370) everything works great EXCEPT the wget call.  Wget times out (can't connect to remote host (x.x.x.x): Connection timed out.

  • The remote host is the exact same host that ESXi booted and installed off of without issue (via HTTP).
  • The interface (vmnic0/vmk0) is up and has a valid IP address.
  • The HTTP host responds normally to pings.
  • The HTTP host responds normally to requests from other systems on the same network.

The HTTP server is on port 8080, is there something funky w/ 6.5 that "blocks" outgoing traffic on port 8080?  I'm stumped!!

Thanks in advance for any input!

3 Replies
rspoto
Contributor
Contributor

A little follow-up on this, the version of busybox in 6.5 is newer than others so I grabbed the older version and tried it.  No dice.

Then, I set up some port forwarding on my server to forward requests from port 80 to the target on 8080, and the wget worked fine.  I changed the port forward to take requests from 81 and forward on, but no dice.  Seems like any port other than 80 just times out.

So, it's certainly something to do with the environment in the 6.5 installation but I don't know what/where to look.  I'd rather not have to do funky port forwarding.

0 Kudos
5h3ph3rd
Contributor
Contributor

I had the same problem in 6.5, I got around it by just disabling the Firewall during the kickstart script before the wget commands, then re enabling it afterwards:

esxcli network firewall set --enabled false

wget ftp:// ftp.example.com/folder/file​​ -P /vmfs/volumes/datastore/folder

esxcli network firewall set --enabled true

I have not tried this in 6.5.0a yet but let us know the results.

Bill76
Contributor
Contributor

turning off the firewall during the file transfer using wget worked for wget https://

0 Kudos