VMware Cloud Community
Vitsm
Contributor
Contributor

ESXi 5.x Dot1q vlan tagged packets not reaching VM

Hi,

ESXi version: 5.5 (licensed version).  Using vSphere windows client for management.

Have a simple setup where vmnic is directly connected to a switch.  Corresponding 'vSwitch' is configured with Vlan as 'All(4095)'.  I presume this enabled VGT vlan trunking mode.

@VM and switch, ports are configured as trunk port.

Now, all untagged traffic (on trunk native vlan) is processed as expected.

However, tagged packets are sent from VM are reaching switch, but not vice versa.  ie tagged packets from switch are not reaching VM itself. 

vmware docs has mentioned that '802.1Q VLAN trunking driver is required inside the virtual machine'.  What is driver and how do we install it for linux VM?

Please let me know if missing any config etc.

Reply
0 Kudos
6 Replies
GMCON
Enthusiast
Enthusiast

4095 means that you are purposely doing Virtual Guest tagging.  Normally a better config is to do Virtual Switch tagging where the vSwitch is responsible for VLAN tags and you have the different VLAN's configured on your vSwitch and it will strip off the VLAN tags before sending to VM.  Since those VLAN tags are not being stripped off though that is why you are having problems.  Here is a good article explaining all of this and how to do what you need and the different purposes

Virtual Nomad: Vlan Tagging and use cases of VLAN ID 4095

Reply
0 Kudos
Vitsm
Contributor
Contributor

Yes, deliberately using VGT, as mentioned earlier.  VST doesn't meet our requirement.  But VGT is not working?

Reply
0 Kudos
GMCON
Enthusiast
Enthusiast

Read the article and it will show you how you have to configure the vm for guest vlan tagging

Reply
0 Kudos
Borja_Mari
Virtuoso
Virtuoso

Hello,

if you want to configure VLAN tagging inside the linux guest, you can check this:

HowTo: Configure Linux Virtual Local Area Network (VLAN) - nixCraft

Anyway, perhaps you should check some guide more specific to the linux distribution of the guest.

Additionally, i would recommend you to check the "Virtual Guest Tagging (VGT)" section in this vmware's kb:

VMware KB: VLAN configuration on virtual switches, physical switches, and virtual machines

Best regards,

Pablo

------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
Reply
0 Kudos
Vitsm
Contributor
Contributor

Thanks for all the responses, but I had already went through all of these links.  All the configuration mentioned is done.  One thing that I didnt is '802.1Q VLAN trunking driver is required inside the virtual machine'.  Which driver is being referred here.

Reply
0 Kudos
Borja_Mari
Virtuoso
Virtuoso

Hello,

the driver, is the 8021q linux (kernel) driver. This is explained in the link i have commented you:

Setting up 802.1q VLAN tagging by loading 8021q Linux kernel driver

First, make sure that the Linux kernel driver (module) called 8021q is loaded:
# lsmod | grep 8021q
If the module is not loaded, load it with the following modprobe command:
# modprobe 8021q

Smiley Wink

------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
Reply
0 Kudos