GregMeathead
Enthusiast
Enthusiast

ESXi 5 storage connectivity issues

Jump to solution

When i was setting up our vsphere infrastructure 2 years ago i did everything according to the "best practices" (Netapp, VMWare and  Cisco).

I had 2 4.0 hosts and i set up storage (NFS and iSCSI) networking as a EtherChannel on a Cisco switch side and both NICs Active and IP HASH load balancing in a ESXi side.

Now, i just added 2 more 5.0 hosts, upgraded vCenter to 5 and wanted to configure the new host to see the storage but that's where the problem comes.

Somehow ESXi5 does not let me use exactly the same configuration, i can not have 2 Active adapters on ESX side and because of this i can not use IP Hash load balancing in this vSwitch.

So, how am i suppose to add Stoarge to new ESXi5 ?

Is EtherChannel no supported on Storage networking anymore on ESXi5?

If i have to stop using EtherChannel on CISCO site that will break my storage conection to both production ESXi 4 hosts.

Any input appreciated.

Thanks

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
jjkrueger
VMware Employee
VMware Employee

Adding adapters through the Software iSCSI GUI is going to bind individual (and generally multiple) VMKernel ports to a single software iSCSI initiator. This is the GUI version of "esxcli swiscsi nic add -n <vmk#> -d <vmhba#>.

In order to configure this for vSphere 5, the VMkernel port NIC teaming settings have to be set up as described in the error.

If you choose not to explicitly bind VMkernel ports to the software initiator, leave the Network Configuration tab empty, and the VMkernel routing table will automatically choose an appropriate VMKernel port to communicate. Based on your description, this is how your vSphere 4 environment is set up.

View solution in original post

0 Kudos
13 Replies
cflath24
Contributor
Contributor

I am unable to replicate your setup in my current environment, but if I am following you correctly..

We create our Management Network with 2 adapters, and by default it places one of the adapters into standby, however you are able to move it to active, and IP hash is one of the available Load Balancing options.

0 Kudos
GregMeathead
Enthusiast
Enthusiast

Somehow i can not do this, this is the error im getting:

Storage.png

I want the adapters to be Active, Standby because this is apparently required by ESXi5 storage networking (was not on ESXi 4)

0 Kudos
cflath24
Contributor
Contributor

The error there states that standby adapters are not supported, if you select vmnic1 and move it up to active do you get any errors?

0 Kudos
aravinds3107
Virtuoso
Virtuoso

Sample Configuration shows for IP hash policy it should be Active/Active Interface.

If its for iSCSI interface should be Active/Unsed , Please check your ESXi4.x host and confirm the settings

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful |Blog: http://aravindsivaraman.com/ | Twitter : ss_aravind
0 Kudos
GregMeathead
Enthusiast
Enthusiast

cflath24 wrote:

The error there states that standby adapters are not supported, if you select vmnic1 and move it up to active do you get any errors?

No, i dont, but i can't have both NIC Active beacuse ESXi 5 storage networking doesnt allow it. That's the problem.

Capture.JPG

0 Kudos
cflath24
Contributor
Contributor

Ok, then I believe as aravinds3107 stated, you must move vmnic1 down to "unused".

0 Kudos
GregMeathead
Enthusiast
Enthusiast

My ESXi 4 storage networking are settings are IP Hash Active/Active because the same NICs support NFS not only SCSI so i have to have redundancy.

And the Cisco switch is configured for etherchannel.

Thats how it looks on ESXi 4 side:

Capture.JPG

0 Kudos
GregMeathead
Enthusiast
Enthusiast

cflath24 wrote:

Ok, then I believe as aravinds3107 stated, you must move vmnic1 down to "unused".

Ok, the problem is since this storage metalwork does iSCSI and NFS i have to have redundancy, so i can not move it to unused. I can move it to Stand-by , BUT if i do so i can not use IP Hash for load balancing because it doesn't support Active/Standby, and IP Hash is the only Load balancing the Etherchannel can be configured with.

Do you follow? it is pretty confusing Smiley Happy

0 Kudos
aravinds3107
Virtuoso
Virtuoso

Just to be sure you are trying to perform similiar setup as your ESXi 4.x hosts, On your ESXi 4.1x host adapter is set to Active/Active and you have mentioned it supports both NFS and iSCSI,

What is the reason for usign Active/Standby on your ESXi 5.0 when you want simliar setup.

I dont thik so we can achieve IP hash policy with Active/Standby

You can check if this related to your issue (http://communities.vmware.com/message/1993999)

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful |Blog: http://aravindsivaraman.com/ | Twitter : ss_aravind
0 Kudos
GregMeathead
Enthusiast
Enthusiast

Aravind Sivaraman wrote:

Just to be sure you are trying to perform similiar setup as your ESXi 4.x hosts, On your ESXi 4.1x host adapter is set to Active/Active and you have mentioned it supports both NFS and iSCSI,

What is the reason for usign Active/Standby on your ESXi 5.0 when you want simliar setup.

I dont thik so we can achieve IP hash policy with Active/Standby

You can check if this related to your issue (http://communities.vmware.com/message/1993999)

Yes, you are correct, i am trying to set up ESXi 5 just like 4.

The reason i have to use Active/Unused (not Active Standby) in 5 is because that is what ESXi requires: (it somehow doesnt support Active/Active storage config anymore).

Capture.JPG

But if i do this i will have no storage network redundancy plus then whats the point of having a EtherChannel on Cisco side?

0 Kudos
aravinds3107
Virtuoso
Virtuoso

I am sorry i am confused with the requirement

Confirm which policy are you looking for Active/Unused or Active /Standby

Screenshot and your earlier comments said you tryng Active/Standby

The reason i have to use Active/Unused (not Active Standby) in 5 is because that is what ESXi requires

You have mentioned now as Active/Unused - This setting is done for iSCSI Connection with Multilple VMkernel ports and then port binding is done

Check this blog for iSCSI Connection

No, i dont, but i can't have both NIC Active beacuse ESXi 5 storage networking doesnt allow it. That's the problem.

Do you mean you are unable to keep both NIC's active?

On your ESXi 4.* Do you have single VMkernel Ports or Multplie VMkernel ports for Storage connection.

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful |Blog: http://aravindsivaraman.com/ | Twitter : ss_aravind
0 Kudos
GregMeathead
Enthusiast
Enthusiast

OK, i will try to clarify it as much as i can:

ESXi 4 setup (production): One Storage VMkernel port per each host. 2 NICs set up in Active/Active mode IP Hash load balancing.

I want to set up ESXi5 the same way so:

I created 1 VMKernel port on each host with 2 NICs in Active/Active mode and IP Hash load balancing

Then i tried to add adapter to iSCSI Storage Adapter but when i try it tells me that i can't because it has to have one NIC active one Unused.

so if i do it this way i will not have to remove one NIC from Active and put it in unused mode which will not be compatibile with IP Hash load balancing, plus it will drop my NFS NIC redundancy.

0 Kudos
jjkrueger
VMware Employee
VMware Employee

Adding adapters through the Software iSCSI GUI is going to bind individual (and generally multiple) VMKernel ports to a single software iSCSI initiator. This is the GUI version of "esxcli swiscsi nic add -n <vmk#> -d <vmhba#>.

In order to configure this for vSphere 5, the VMkernel port NIC teaming settings have to be set up as described in the error.

If you choose not to explicitly bind VMkernel ports to the software initiator, leave the Network Configuration tab empty, and the VMkernel routing table will automatically choose an appropriate VMKernel port to communicate. Based on your description, this is how your vSphere 4 environment is set up.

0 Kudos