JanTichavaWega
Contributor
Contributor

ESXi 5.5 restart USB subsystem – all USB devices are gone, reboot of host sometimes helps

Hello everybody,

no USBs are currently working on our server. We want connect USB3 HDD to ESXi and then to VM, which will be for backups. It’s working fine and fast, as we want – but.

Problem is, that if USB device is attached to particular VM. I’m not 100 % sure with following steps, so far I got this problem only for the third time, but I’m trying to fix it without rebooting whole server.

One steps, how I “killed” USBs on Windows 8 virtual machine:

  1. Restart/Power on
  2. After new boot, do not login to Windows
  3. Restart Windows (with button on to bottom right corner on login screen)
  4. Close Console

At first, it looks fine, but then I can’t connect to Console, Windows is not responding on ping and Remote Desktop is not working too.

Different steps:

  1. Restart/Power on
  2. Log in
  3. Check, that USB HDD is connected
  4. Use PuTTY for connection to terminal via COM1 (Sun server)
  5. Close PuTTY
  6. Reboot Windows (do not Safely remove HDD)
  7. Windows ends correctly
  8. New boot freezes during displaying Windows logo for a few minutes
  9. Then Windows boot up, USB HDD is missing and there is an error in Events

After some time (a few minutes), I get an error, which is logged in VM Events:

Event Details:

Type:     warning

Description:        Warning message on <VM name> on <server name> in ha-datacenter: USB device "Western Digital My Book 1230" is no longer connected to the virtual machine.

Time:     23.1.2015 11:30:28

Error Stack:

USB device "Western Digital My Book 1230" is no longer connected to the virtual machine.

After this error, VM is working fine again, without any problems, except USB and sometimes COM.

Since this happens, no USB 3 and no USB 2 are working on server. I can connect above mentioned USB HDD to any port or I can connect USB Memory Stick and nothing is detected. Also lsusb doesn’t detect these USB devices and listing takes a few minutes. I also have suspicion, that serial port COM1 stopped working because of this or at least, there is some connection.

When this happened for the first time, I fixed it by many reboots of whole ESXi server.

When this happened for the second time, I fixed it with only reboot of whole ESXi server. I didn’t touch cables at all, so it shouldn’t be caused by malfunctioning cable (I also tried different one before with no success and I also tried USB HDD on different computer and works perfectly fine.) By the way, also COM1 port in VM started to work again (is mapped to real COM1).

I was trying to simulate this problem, but I can’t do it right, I don’t know how. There are too many things, which might be related…

When USBs weren’t working, I tried executing /sbin/services.sh restart, but it didn’t fix the issue – lsusb wasn’t still able to printout my USB HDD.

Both cases happened only during powering off, so it is not so big issue if it happens if I know quick fix for it. I need to find some way, how to restart whole USB subsystem on ESXi server, to get USB working without affecting running VMs.

As I mentioned, that there might be some connection between USB and COM1 – once even happened, that whole ESXi server boot halted, while serial cable was connected to the port. (Other end of the cable is connected to old Sun server.)

Used hardware:

Supermicro X10DRi motherboard with integrated USB 2 and USB 3 and serial port

WD My Book USB 3.0 (WDBFJK0040HBK-EESN)

Used software:

VMware ESXi 5.5 2302651 (installed 5.5 U2 + 2 patches)

Windows 8.1 64b with VMware Tools installed

Windows Server 2012 R2 64b with VMware Tools installed

What I found on the internet:

Rebooting ESXi from a USB drive fails with error: URB timed out - USB device may not respond (1010940)

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=101094...

This is very similar, but I’m not booting from that device, so I don’t know, whether it’s related and anyway, I don’t know, what should I do with is. From my point of view, it should work with any USB HDD.

ESX host get "URB timed out - USB device may not respond" during reboot ?

https://communities.vmware.com/thread/269165

This is a little bit old post and it’s also while booting from USB.

USB hard drive stops responding

https://communities.vmware.com/thread/456819

This is most likely my problem, but there is no solution – only the link to my first link found on the internet.

I would really appreciate any tip, help or suggestions.

Thank you in advance.

0 Kudos
6 Replies
JanTichavaWega
Contributor
Contributor

I still don't know, what is causing this issue and we will go different way, so we don't need USB HDD.

If somebody need, these are the steps, that fix USB:

  • check lsusb don't display USB HDD
  • power off VM
  • remove USB device from VM configuration
  • physically disconnect USB
  • (probably also physically disconnect serial cable - not tested!)
  • power off ESXi
  • wait half minute
  • power on ESXi
  • enter BIOS
  • change nothing and save settings and reset
  • wait till server boots up
  • disconnect HDD from power
  • wait a while
  • connect HDD to power
  • connect HDD to USB 2
  • should be listed in lsusb
  • disconnect from USB 2 and connect HDD to USB 3
  • it's working fine again
0 Kudos
VBAdmin
Contributor
Contributor

Hi,

Did you ever determine a solution for this painful issue?

0 Kudos
berndweyand
Expert
Expert

i'm really sure he found a solution in the past 6 years

0 Kudos
VBAdmin
Contributor
Contributor

Great comment 🙂

0 Kudos
scott28tt
VMware Employee
VMware Employee

@VBAdmin 

You asked the same question on 2 old threads, each thread being about an entirely different product (ESXi and Workstation) - you might wish to search for a resolved thread which matches whichever of those products you are experiencing the same issue with...

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------
VMware Training & Certification blog
0 Kudos
continuum
Immortal
Immortal

I agree with Bernds answer.
The issue posted in 2015 apparently was so obscure or unimportant that nobody looked into it or followed it up.
Only new bit we have is the attribute: painful
Lets assume that the problem in 2015 was trivial and OP solved it and never came back

 

Ulli

 

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos