jmay
Enthusiast
Enthusiast

ESXi 5.5 latest patch, OS X 10.9 guest, more than one virtual core message on boot

I'm using ESXi 5.5 with the latest patch, all supported hardware as per VMWare's database.  With an OS X 10.9 guest OS, VM hardware v10 and set to OS X 10.9 in settings.

My problem is that on boot, after any OS update, I get a message:

"Your Mac OS guest might run unreliably with more than one virtual core. It is recommended that you power off the virtual machine, and set its number of virtual cores to one before powering it on again. If you continue, your guest might panic and you might lose data."

that prevents further booting until addressed via vSphere Web Client.

Searching past discussions from a while ago says it was a bug that was supposedly fixed, but obviously is not.

Why is this occurring?  Anyone know how to resolve it?  Thanks for any help!

- John

0 Kudos
4 Replies
dariusd
Leadership
Leadership

Could you please provide the vmware.log file from inside your OS X 10.9 VM's directory on the datastore?  (Please don't copy and paste the log file into your reply... use the file attachment facility available when composing a reply in this thread.)

We've been fixing known causes of this issue as they arise, but it is very possible that there is some new cause triggering the same message.  The log file might provide us with a clue as to what's happening.

Thanks,

--

Darius

0 Kudos
jmay
Enthusiast
Enthusiast

Please find attached.  Thanks for your help!

- John

0 Kudos
dariusd
Leadership
Leadership

OK, I think I've figured out what has happened.  I'd like to send you a replacement EFI firmware ROM image to try, plus instructions for its use.  Let me know if you would be OK with trying out the fix for me.

Cheers,

--

Darius

0 Kudos
jmay
Enthusiast
Enthusiast

Please do proceed accordingly.  Thanks!

- John

0 Kudos