trungminh
Enthusiast
Enthusiast

ESXi 5.5 cannot detect the Hitachi storage

Jump to solution

Hello experts,

I just installed fresh ESXi 5.5u3 and connect to the Hitachi Storage HUS110.

I already configured all parts as needed on HUS110 to connect SAN switch and HBA on server also. I think this is fine.

But after that ESXi still can not detect LUN (2Tb) of HUS110 to Add Storage implement.(Add Storage is blank)

Do i need to install more add-on HUS110 on ESXi. If yes, which is the add-on to do?

0 Kudos
1 Solution

Accepted Solutions
Techie01
Hot Shot
Hot Shot

From the output, it shows that ESX HBA is able to login to the storage. So looks to be good from ESX side and zoning. Can you please confirm the following

1. On the storage side, is the lun masking done properly. Are the LUNS mapped to the same esx host ( cross verify the wwns)

2. Is it possible to create a lun of small size, say 5GB and check if the lun is visible on esx side. 2TB is a limit value and there could be some issue with storage or driver

3.Can you post the output of ' esxcli storage core claimrule list'

View solution in original post

0 Kudos
12 Replies
a_p_
Leadership
Leadership

Do you see the HBA and the LUN in the Storage Adapters section?


André

0 Kudos
trungminh
Enthusiast
Enthusiast

Hello

On Hitachi Storage i can see the HBA.

So exactly, the ESXi can Add Storage from EMC CX4-120 but with HUS110 is not successful.

Any help is appreciated,

0 Kudos
a_p_
Leadership
Leadership

The "Storage Adapters" section I was asking for is the one in the vSphere Client. Do you see the presented LUNs from the Hitachi system there, or don't you see the Hitachi LUNs at all on the ESXi host?

André

0 Kudos
grasshopper
Virtuoso
Virtuoso

Have you tried rebooting the ESXi host?  Hitachi likes a reboot (of ESXi) for whatever reason.

0 Kudos
trungminh
Enthusiast
Enthusiast

Hello,

I can see the HBA on Starage adapter as attached file.

I also can not see the LUNs from Hitachi from Add Storage and all ESXi also.

I used ESXi.5.5 on HP G9 server with ISO image: VMware-ESXi-5.5.0-Update3-3568722-HPE-550.9.5.0.33-Apr2016.

Do i miss any configuration?

Any help is appreciated,

Best regards,

0 Kudos
trungminh
Enthusiast
Enthusiast

Hello grasshopper,

Hitachi storage did not reboot, but I already reboot ESXi host but not successful.

Best regards,

0 Kudos
LNCHAARY
Contributor
Contributor

Hi,

On the first place check if you are actually able to see the LUN from ESXi storage device tab.

***** vCenter -> ESXi -> Configuration TAB -> Storage -> Select "Devices"TAB on right side pane *****

- Make sure you are able to see the LUN (refer with Identified name or LUN ID). If you are able to see it then try login to ESXi host directly through vSphere client and then try to "add storage" and see if you are able to create datastore.

Thanks,

Chaary

0 Kudos
Techie01
Hot Shot
Hot Shot

Can you share output of /usr/lib/vmware/vmkmgmt_keyval/vmkmgmt_keyval -a and esxcfg-scsidevs -a

0 Kudos
trungminh
Enthusiast
Enthusiast

Hello,

Here is my out put:

~ # /usr/lib/vmware/vmkmgmt_keyval/vmkmgmt_keyval -a and esxcfg-scsidevs -a

Listing all system keys:

Key Value Instance:  vmhba3/qlogic

Listing keys:

Name:   ADAPTER

Type:   string

value:

QLogic PCI to Fibre Channel Host Adapter for HPAK344A:

        FC Firmware version 8.01.02 (90d5), Driver version 1.1.58.0

Host Device Name vmhba3

BIOS version 2.16

FCODE version 2.03

EFI version 2.22

Flash FW version 5.03.15

ISP: ISP2532, Serial# MY5548209D

MSI-X enabled

Request Queue = 0x410afaca8000, Response Queue = 0x410afacc9000

Request Queue count = 2048, Response Queue count = 512

Number of response queues for CPU affinity operation: 2

CPU Affinity mode enabled

Total number of MSI-X interrupts on vector 0 (handler = ff42) = 2298

Total number of MSI-X interrupts on vector 1 (handler = ff43) = 3

Total number of MSI-X interrupts on vector 2 (handler = ff44) = 6496

Total number of MSI-X interrupts on vector 3 (handler = ff45) = 2205

Device queue depth = 0x40

Number of free request entries = 1518

FAWWN support: disabled

Total number of outstanding commands: 0

Number of mailbox timeouts = 0

Number of ISP aborts = 0

Number of loop resyncs = 1

Host adapter:Loop State = [READY], flags = 0x202a260

Link speed = [8 Gbps]

Dpc flags = 0x0

Link down Timeout =   008

Port down retry =  010

Login retry count =  010

Execution throttle = 2048

ZIO mode = 0x6, ZIO timer = 1

Commands retried with dropped frame(s) = 0

Product ID = 4953 5020 2532 0002

NPIV Supported : Yes

Max Virtual Ports = 254

SCSI Device Information:

scsi-qla1-adapter-node=50014380330e9ef7:010a00:0;

scsi-qla1-adapter-port=50014380330e9ef6:010a00:0;

Name:   TARGET

Type:   string

value:

Driver version 1.1.58.0

Host Device Name vmhba3

FC Target-Port List:

scsi-qla1-target-0=5006016344604fb1:010000:0:Online;

scsi-qla1-target-1=5006016b44604fb1:010100:1:Online;

Name:   NPIV

Type:   string

value:

Driver version 1.1.58.0

Host Device Name vmhba3

NPIV Supported : Yes

Key Value Instance:  vmhba2/qlogic

Listing keys:

Name:   ADAPTER

Type:   string

value:

QLogic PCI to Fibre Channel Host Adapter for HPAK344A:

        FC Firmware version 8.01.02 (90d5), Driver version 1.1.58.0

Host Device Name vmhba2

BIOS version 2.16

FCODE version 2.03

EFI version 2.22

Flash FW version 5.03.15

ISP: ISP2532, Serial# MY554820AC

MSI-X enabled

Request Queue = 0x410afabb0000, Response Queue = 0x410afabd1000

Request Queue count = 2048, Response Queue count = 512

Number of response queues for CPU affinity operation: 2

CPU Affinity mode enabled

Total number of MSI-X interrupts on vector 0 (handler = ff3e) = 2294

Total number of MSI-X interrupts on vector 1 (handler = ff3f) = 11

Total number of MSI-X interrupts on vector 2 (handler = ff40) = 6133

Total number of MSI-X interrupts on vector 3 (handler = ff41) = 1852

Device queue depth = 0x40

Number of free request entries = 387

FAWWN support: disabled

Total number of outstanding commands: 0

Number of mailbox timeouts = 0

Number of ISP aborts = 0

Number of loop resyncs = 1

Host adapter:Loop State = [READY], flags = 0x202a260

Link speed = [8 Gbps]

Dpc flags = 0x0

Link down Timeout =   008

Port down retry =  010

Login retry count =  010

Execution throttle = 2048

ZIO mode = 0x6, ZIO timer = 1

Commands retried with dropped frame(s) = 0

Product ID = 4953 5020 2532 0002

NPIV Supported : Yes

Max Virtual Ports = 254

SCSI Device Information:

scsi-qla0-adapter-node=50014380330e9cd3:010a00:0;

scsi-qla0-adapter-port=50014380330e9cd2:010a00:0;

Name:   TARGET

Type:   string

value:

Driver version 1.1.58.0

Host Device Name vmhba2

FC Target-Port List:

scsi-qla0-target-0=5006016244604fb1:010000:2:Online;

scsi-qla0-target-1=5006016a44604fb1:010100:3:Online;

Name:   NPIV

Type:   string

value:

Driver version 1.1.58.0

Host Device Name vmhba2

NPIV Supported : Yes

Key Value Instance:  MOD_PARM/qlogic

Listing keys:

Name:   DRIVERINFO

Type:   string

value:

Driver version 1.1.58.0

Module Parameters

ql2xlogintimeout = 20

qlport_down_retry = 10

ql2xplogiabsentdevice = 0

ql2xloginretrycount = 0

ql2xallocfwdump = 1

ql2xmdcapmask = 31

ql2xenablemd = 1

ql2xioctltimeout = 66

ql2xioctltimertest = 0

ql2xextended_error_logging = 0

ql2xdevdiscgoldfw = 0

ql2xattemptdumponpanic= 0

ql2xfdmienable = 1

ql2xmaxqdepth = 64

ql2xiidmaenable = 1

ql2xusedefmaxrdreq = 0

ql2xenablemsix = 1

ql2xenablemsi24xx = 1

ql2xenablemsi2422 = 0

ql2xshiftctondsd = 6

ql2xdontresethba = 0

ql2xdontresethba_83xx = 0

ql2xoperationmode = 1

ql2xintrdelaytimer = 1

ql2xcmdtimeout = 20

ql2xexecution_throttle = 0

ql2xmaxsgs = 0

ql2xmaxlun = 65535

ql2xmqqos = 1

ql2xmqcpuaffinity = 1

ql2xfwloadbin = 0

ql2xloadfwbin = 1

ql2xdbwr = 1

ql2xbypass_log_throttle = 0

ql2xuseshadowregisters = 0

qlfxdisablewatchdogtimer = 0

qlfxdisablereset = 0

qlfxmaxqdepth = 32

qlfxmaxqueues = 1

qlfxmaxlun = 65535

qlfxtargetreset = 1

qlfxcmdtimeout = 20

qlfxmaxsgs = 0

qlfxmaxxfersize = 0

Any help is appreciated,

Best regards,

0 Kudos
trungminh
Enthusiast
Enthusiast

Hello,

The main is i can not see the LUNs from Hitachi storage to process the next steps.

Best regards,

0 Kudos
Techie01
Hot Shot
Hot Shot

From the output, it shows that ESX HBA is able to login to the storage. So looks to be good from ESX side and zoning. Can you please confirm the following

1. On the storage side, is the lun masking done properly. Are the LUNS mapped to the same esx host ( cross verify the wwns)

2. Is it possible to create a lun of small size, say 5GB and check if the lun is visible on esx side. 2TB is a limit value and there could be some issue with storage or driver

3.Can you post the output of ' esxcli storage core claimrule list'

0 Kudos
trungminh
Enthusiast
Enthusiast

Hello,

I was not selected the WWNs to add when Create host group on Hitachi storage.

Not it all fine.

Thanks all.

0 Kudos