TheKid7
Enthusiast
Enthusiast

ESXi 5.1 Remote Access To Blade Using IE11 - Invalid Certificate Error

In the near future, I need to shutdown my VMware Management Server VM and modify some settings.  Since the VMware Management Server will be down, I will not be able to use vSphere Client to access these settings.

In the past I was able to use IE10 to access each individual Blade.  Now when I enter the desired Blades IP address in IE11 I get an error something about an Invalid Certificate.

How do I correct this issue of not being able to access the individual Blades with IE11?

Thank in Advance.

0 Kudos
3 Replies
TheKid7
Enthusiast
Enthusiast


I forgot that you Do Not use IE to access the individual Blades.  You use vSphere Client to access both vSphere Server (VM Management Server) and vSphere Client (Individual Blades).

However, I have another problem now:  The "Use Windows session credentials" of VMware vSphere Client no longer saves the Password when the box is checked.  The Name of the Windows Server where vSphere Server 5.1 is installed followed by 'backslash' Username is shown (not-changeable) and No Password when the "Use Windows session credentials" box is checked.  I had this problem occur in the past, and it eventually went away.  I tried Restarting both the VM Management Server and the Windows Server where vSphere Server 5.1 is installed, but the problem remains.  How can I correct this problem?

0 Kudos
bspagna89
Hot Shot
Hot Shot

Hi,

I am trying to understand what you are asking. First, we have an IE 11 certificate issue. Are you getting something where it says the certificate is invalid and you have to click to close the browser? Did you try adding https://serverIPorNAME in Trusted Sites in internet explorer?

The second issue -- Use Windows credentials box is locking the username because it will attempt to pass the current logged in username/password. The grey boxes on Username and Password are by design. If you uncheck the box, you can use any username/password.

Does this help/ Make sense? Let me know.

New blog - https://virtualizeme.org/
0 Kudos
bspagna89
Hot Shot
Hot Shot

Also, If adding those to trusted sites doesn't work.. You will need to perform the following :

Open command prompt running as administrator and execute the following :

certutil -setreg chain\minRSAPubKeyBitLength 512


That command will lower the key length that will be accepted. VMware 5.1 and lower generate certificates that are lower than 1024 and this has been increased in one of the newer patches from Microsoft.

New blog - https://virtualizeme.org/
0 Kudos