ESXi 5.0: How can I mount USB ports of a physical machine to a VM guest OS

ESXi 5.0: How can I mount USB ports of a physical machine to a VM guest OS (WinServer 2008R2 Standard)

To finish a server migration of DATEV (the leading tax consulting software in germany) from a physical server to a VMware ESXi 5.0.0 U1 Hypervisor on a HP Proliant (ESXi 5.1 is still not supported), I need urgend a solution for a USB-Stick based License-Dongle.

(VMware ESXi 5.0 is the recommended solution of DATEV, but they give no support to "details of VMware" ...!)

For activating DATEV services, it is absolute necessarily to use this USB-SmartCard License-Dongle on the VM Guest OS.

I added the "USB-Controller" to the "hardware" of my VM (Windows Server 2008R2 Standard) and rebooted the VM.

The new USB-Controller get recogniced - I get the USB symbol in the taskbar right side.

But when I add the License-Dongle to the physical server, I get any reaction.

I tried to use a 512MB USB-Memory-Stick from Kingston and a newer 2GB Stick from SanDisk even with no reaction!

The installation of dedicated drivers (guest OS) to the DATEV-License-Dongle fails, cause Installation-manager detects no corresponding device.

(The USB-devices are technically OK and tested on a Win7 64 PC and Windows Server 2003.)

Mounting the USB-Controller of the local PC to the VM is possible, but same effect, no device detection.

Am I doing something wrong?!

Has anyone a solution?

Tags (3)
0 Kudos
3 Replies

I found today a simple and efficient solution:

The solution is, that the device is pluged in before you start

and to add "USB-device" after "USB-controller" is added!

1.     Plug USB-Device in VMware Server

     (The Datev USB-SimCard-Reader is a "Kobile-Type, SCM SCR 335 ")

2.     Add "USB-Controller" in VM

     ->Guest-OS is detecting USB-Controller but no device

3.     Add "USB-device" in VM

     ->Guest-OS is detecting "SCR 335", after some seconds

4.     Manual installation of the "mIdentity"  Datev-driver


     chose the correct one, installation is finished in 10 seconds!


How you see is the solution much easier than all the threads about RDP- sessions and registriy edits ...

Thanks to the engineers of VMware, they do a very well job!

But the guy's and or girls who wrote the manuals should remember,

that a simple example explains and helps sometimes better than a hundred words about funktionality!

As I do not understand, there is any information about at DATEV,

even VMware 4.1, 4.5 and 5.0 is cetrified by VMware and the USB-License Dongle is one of the major parts of the DATEV-solution.

There is a good chance for them to do a better job on their manuals and support ...

Thanks to all who have thought about the problem!

0 Kudos

The idea is, that the "USB-controller" can be added to several VM-Guest-OS.

But a  "USB-device" can be added only once to a dedicated VM-Guest-OS!!!

0 Kudos


I have the same issue. Did you ever manage to resolve this issue? Have you tried with another USB modem?

Thank you!

0 Kudos