mymarei
Contributor
Contributor

ESXi 4 VMs migrating from one host to another without HA

Jump to solution

We are facing an automatic migration issue with ESXi VMs migrating between clustered hosts. Even though we have HA disabled and no apparent reason for the migration. We have two VMs residing on one host and that host is working normally. However I have noticed that when we powered off either of the VMs and on again it jumps to a different host in the cluster.

Now the host tasks log shows that the migration was done by SYSTEM at the time of power on. And one time one of the VMs migrated even without power off and with a similar log entry showing it was done by system. Can this happen due to resource shortage on the host even when HA is disabled or are there other reasons this might happen?

0 Kudos
1 Solution

Accepted Solutions
Lessi001
Enthusiast
Enthusiast

Hi,

I am pretty sure that this is the reason for your described behaviour.

Regards

Andi

There are 10 types of people in this world. Those who understand binary, and those who do not.

View solution in original post

0 Kudos
6 Replies
Lessi001
Enthusiast
Enthusiast

Hi,

is it possible that you have activated DRS?

Regards

Andi

There are 10 types of people in this world. Those who understand binary, and those who do not.
iw123
Commander
Commander

Hi,

Yes, the behaviour you are describing is likely to be DRS - do you still have that enabled on your cluster?

ha.jpg

*Please, don't forget the awarding points for "helpful" and/or "correct" answers
mymarei
Contributor
Contributor

Thanks for your quick answers. I didnt notice it but most likely it is the case as it fits. Will recheck and update the thread with my finds.

0 Kudos
Lessi001
Enthusiast
Enthusiast

Hi,

I am pretty sure that this is the reason for your described behaviour.

Regards

Andi

There are 10 types of people in this world. Those who understand binary, and those who do not.
0 Kudos
Silica_V
Hot Shot
Hot Shot

When there is a DRS active on the cluster and if there is load on the first ESX host, then it will migrate the VM to another ESX host.

Check the following:

1. Check the load on ESX host

2. Check the DRS cluster settings

3. Check the Logs for more information.

Regards,

Silica V.

Regards, Vijaykumar B.
0 Kudos
mymarei
Contributor
Contributor

It was DRS as expected. Thanks for the help guys!

0 Kudos