linglong768
Contributor
Contributor

ESXi 4.1 HA configure error!!!

Jump to solution

I have 2 esxi 4.1 hosts ,when configure the HA ,the error apears bellow:

HA agent on xx.xx.xx.xx in cluster xx in xx has an error:

cmd addnode failed for primary node:error creating ramdisk for HA agent configuration,:unknown HA error

but other 2 esx 4.1 host is ok in this cluster

0 Kudos
1 Solution

Accepted Solutions
chadwickking
Expert
Expert

Unjoin the host from vcenter -

SSH to server and run: (technical support mode)

service mgmt-vmware stop

service vmware-aam stop

service vmware-vpxa stop

Rejoin the host back to vCenter - it should reinstall the agents. I had this problem today and this fixed. If it gets tougher there are alternatives.

Stopping servics see:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100349...

Worse case scenario:

Right-click on the ESXi host and click Disconnect. This disconnects the ESXi host from the VirtualCenter Inventory.

Log in to ESXi Troubleshooting Mode. For more information, see Tech Support Mode for Emergency Support (1003677).

Uninstall the vpxa and aam components from the VMware ESXi host using the following commands:

/opt/vmware/uninstallers/VMware-vpxa-uninstall.sh

/opt/vmware/uninstallers/VMware-aam-ha-uninstall.sh

Right-click on the ESXi host and click Connect. This initiates a re-install of the vpxa agent.

Add the host to the appropriate cluster. This initiates a re-install of the aam agent.

Rejoin to cluster.






Cheers,

Chad King

VCP-410 | Server+

Twitter: http://twitter.com/cwjking

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

Cheers, Chad King VCP4 Twitter: http://twitter.com/cwjking | virtualnoob.wordpress.com If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

View solution in original post

0 Kudos
17 Replies
FrisoAkkerman
Contributor
Contributor

Hi, what you can try is to disable HA and DRS at the cluster level and when that's finished enable it again.

0 Kudos
Maximenu
Hot Shot
Hot Shot

Hi linglong

Try this solution.

Remove the HA from the cluster and then re-apply HA to it again. When all ESX hosts in the cluster have had HA re-enabled you should see that the HA error previously seen has now gone. And try to disconnect the server (The HA agent will be remove) and re-connect.

Smiley Happy

Javier Galvez

IaaS Evangelist

Joined the VMTN Community in Dic, 2004

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.
0 Kudos
linglong768
Contributor
Contributor

thank you for both of you , i have tried it,no worked. any idears?

0 Kudos
chadwickking
Expert
Expert

Unjoin the host from vcenter -

SSH to server and run: (technical support mode)

service mgmt-vmware stop

service vmware-aam stop

service vmware-vpxa stop

Rejoin the host back to vCenter - it should reinstall the agents. I had this problem today and this fixed. If it gets tougher there are alternatives.

Stopping servics see:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100349...

Worse case scenario:

Right-click on the ESXi host and click Disconnect. This disconnects the ESXi host from the VirtualCenter Inventory.

Log in to ESXi Troubleshooting Mode. For more information, see Tech Support Mode for Emergency Support (1003677).

Uninstall the vpxa and aam components from the VMware ESXi host using the following commands:

/opt/vmware/uninstallers/VMware-vpxa-uninstall.sh

/opt/vmware/uninstallers/VMware-aam-ha-uninstall.sh

Right-click on the ESXi host and click Connect. This initiates a re-install of the vpxa agent.

Add the host to the appropriate cluster. This initiates a re-install of the aam agent.

Rejoin to cluster.






Cheers,

Chad King

VCP-410 | Server+

Twitter: http://twitter.com/cwjking

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

Cheers, Chad King VCP4 Twitter: http://twitter.com/cwjking | virtualnoob.wordpress.com If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

View solution in original post

0 Kudos
vmfan96
Contributor
Contributor

Hello everyone im having the same issue on my ESXi 4.1 servers.

Not sure if Linglong was able to resolve his issue with any of the mentioned fixes.

I tried all of the recommended fixes above but was not able to get arround the error...

"Error creating Ramdisk for HA agent configuration.."

Do anyone know where the Ramdisk is being created? is this a permission or space related error?

ESXi server is installed on a 10GB hard disk. So there plenty of space.

Thanks,

0 Kudos
sergio_us
Contributor
Contributor

Hello everyone, I am having the same issue on my lab of ESXi 4.1 servers.

I have tried all the above workarounds to solve it, and none of them have worked.

"Error creating Ramdisk for HA agent configuration.."

The problem is only with HA , if, in the same cluster, i disable HA and add the host, everything works.

I have checked dns, conectivity etc for Ha to work properly. No problems detected.

Last, I tried the same test wih vcenter 4.0 update 2 and esx 4.0 update 2 and with vcenter 4.1 and esx4.1 and i don´t have this error, it seems a problem with esxi 4.1.

ESXi server is installed on a 8GB hard disk.

Thank you very much.

0 Kudos
pauljawood
Enthusiast
Enthusiast

Hi,

I have the same issue as the people above along with trying the solutions with no success. The LAB I have built is within VMware Workstation latest version and is setup as below:

Windows 2008 R2 x64 AD

Windows 2008 R2 x64 VC (SQL 2008 R2 x64 and 32bit ODBC for UDM)

ESXi 4.1

ESXi 4.1

If I replace the ESXi 4.1 hosts for ESX 4.1 then everything works as expected but with ESXi 4.1 HA fails. Whilst checking the aam log files I have noticed that under the addnode log file the following error is logged:

10/28/10 11:52:07 active primary is ''

10/28/10 11:52:07 command is 'listnodes'

10/28/10 11:52:07 attempting to find an active primary.

10/28/10 11:52:07 command is '/opt/vmware/aam/bin/ftcli -domain vmware -cmd "la -l"'

10/28/10 11:52:07 Trying to talk to self ('labnode1'), yet there is no sites file.

10/28/10 11:52:07 Could not connect to any node to find an active primary .

10/28/10 11:52:07 could not find an active primary on which to execute the command.

10/28/10 11:52:07

10/28/10 11:52:07 VMwareerrortext=Error creating ramdisk for HA agent configuration.

10/28/10 11:52:07 VMwareerrorcat=internalerror

10/28/10 11:52:07 Failure location:

10/28/10 11:52:07 function main::myexit called from line 1087

10/28/10 11:52:07 function main::add_aam_node called from line 210

10/28/10 11:52:07 VMwareresult=failure

10/28/10 11:52:07 Total time for script to complete: 0 minute(s) and 0 second(s)

This looks more like a code error within ESXi 4.1 than anything else but if a solution has been found please can it be shared.

-


If you found this helpful then please leave some points.

If you found this helpful then please leave some points.
0 Kudos
sergio_us
Contributor
Contributor

Hello, i found that giving the esxi4.1 virtual machines in workstation more memory (3GB to each esxi virtual machine, previously they had 2 GB), I could configure HA without problems.

hope this helps...

0 Kudos
pauljawood
Enthusiast
Enthusiast

Hi All,

Please find below my finding which are some what odd.

Basically as Sergio_us suggested you need to give ESXi 4.1 more than 2Gb of RAM that is the minimum as per the requirements document ('2GB RAM minimum. For upgrades, 3GB RAM is required if the ESXi host is managed by vCenter Server.'

Now as you can see that 2Gb is the min but then next part is not so clear. 'For upgrades, 3Gb is required if the ESXi host is managed by vCenter Server' which means does it need 3Gb if its managed or if its an upgrade ?

Anyway I managed in workstation to configure the host with 2252Gb each and HA installed fine. I have lots of free disk space on the local VMFS but it seems that ESXi must write out to memory to enable the HA ramdisk (could be a hint in what it is trying to do).

So as I have said is the question that if you want to enable HA and have a running lab in a workstation then you will need to at min run 2252Gb or ram to get HA installed and configured.

I hope this helps clear up the questions that have been asked and others that are trying to configure a lab on a laptop\pc can get some help from this post.

If you found this helpful then please leave some points.

If you found this helpful then please leave some points.
0 Kudos
admin
Immortal
Immortal

I increased the RAM to 2252MB on each ESXi4.1 hosts and all is fine, I knew it was not name resolution.  Thanks chaps...

0 Kudos
EpsI
Enthusiast
Enthusiast

Hi guys, found this tip very useful.... cheers

0 Kudos
vmfan96
Contributor
Contributor

Giving more RAM worked for me too.  Thanks !!!

0 Kudos
chakrit
Contributor
Contributor

Thank you very much! :smileylaugh:

0 Kudos
dkfbp
Expert
Expert

Thanks for the solution. I was thinking scratchconfig but of course it was just add more memory to the host 🙂

Best regards Frank Brix Pedersen blog: http://www.vfrank.org
0 Kudos
cho9045
Enthusiast
Enthusiast

I had the same problem.

By increasing RAM size of ESXi 4.1 host from 2GB to 2.5GB, all works fine now. As suggested in this post I think it RAM size issue on ESXi4.1

Before this I have tried some suggestions from KB article those includes enabling scratch swap, renaming management network, host name resolution and reconnecting ESXi4.1. Now I am sure renaming management network and enabling scratch swap are not relevant to the problem. Just increasing RAM size fixes it. scratch swap is not enabled and menagement network name unchanged. I configured HA with ESX4.1 and ESXi4.1 so management network name is different. one is 'Service Console' and the other is 'Management Network'.

Thanks for the all suggestions posted here.

0 Kudos
benwayj
Contributor
Contributor

It really is a Monday. I'm not following you on where you adding RAM.

Since ESXi doesn't have a service console I didn't think you had to set aside RAM anymore.

I have one ESXi 4.1 fully patch server having an issue were the HA fails to configure. This is after a reboot from this weekend. (Servers all got reracked and CNA cards installed)

thanks,jb

0 Kudos
cho9045
Enthusiast
Enthusiast

Hi,

I assume that you're testing ESXi in virtual environment. So you can add more memory by editting virtual machine configuration.

I was testing ESXi 4.1 virtial machines in VMware Workstation.

If you're using physical server for ESXi 4.1 then I think you need more RAM installed phydically.

Let me know more about your environment. Is it virtual or physical? How many RAMs configured for ESX4.1?

Regards,

Zchangho

From ChangHo's iPhone

2011. 10. 18. 오전 12:44 benwayj <communities-emailer@vmware.com<mailto:communities-emailer@vmware.com>> 작성:

VMware Communities<http://communities.vmware.com/index.jspa>

ESXi 4.1 HA configure error!!!

reply from benwayj<http://communities.vmware.com/people/benwayj> in VMware ESX™ 4 - View the full discussion<http://communities.vmware.com/message/1847136#1847136

0 Kudos