mdav1s
Contributor
Contributor

ESX WWPNs from command line are different to those displayed in the GUI

The fibre HBAs in my ESX host (V6.7) are showing the correct WWPN's when I run "esxcli storage core adapter list" from the command line.

Relevant output below:
vmhba1 lpfc link-up fc.20000090fa7f3704:10000090fa7f3704 Second Level Lun ID (0000:16:00.0) Emulex Corporation Emulex LPe12000 8Gb PCIe Fibre Channel Adapter
vmhba2 lpfc link-up fc.20000090fa7f3705:10000090fa7f3705 Second Level Lun ID (0000:16:00.1) Emulex Corporation Emulex LPe12000 8Gb PCIe Fibre Channel Adapter

 

However the ESX GUI shows completely different WWPNs for the hba's shown above. 

Both vmhba1 & vmbha2 shows the WWPN as: 11:52:92:21:27:28:47:78:75

Therefore if I present a LUN to the correct WWPN nothing is picked up.

Thoughts?

0 Kudos
8 Replies
scott28tt
VMware Employee
VMware Employee

ESXi has a dedicated area in VMTN, thread reported asking moderators to move it there.


-------------------------------------------------------------------------------------------------------------------------------------------------------------
VMware Training & Certification blog
0 Kudos
a_p_
Leadership
Leadership

That's interesting. I didn't notice this yet.

Just to clarify, do you see this from the ESXi host's Web UI, or from the vCenter Server's Web UI?

André

0 Kudos
e_espinel
Expert
Expert

Hello.
Do you have in the eSXi host 2 independent physical Emulex adapters (one port) ?
Do you have on the ESXi host one physical Emulex adapter with two ports ?

In the Emulex FC Adapter the WWPN format is
is 10XXX
If the Emulex FC adapter has two ports the WWPN will be almost the same only different in the last two digits and usually they are consecutive.
The WWNN (Worldwide Node Name) will be the same for the Emulex FC adapter no matter how many ports the adapter has.
The Emulex format of the WWNN is 20XXX.

WWNNs cannot be identical for different adapters or for different ports of the same adapter for any reason.

Execute the following command to be sure of the WWN of the FC HBAs

# esxcli storage san fc list

 

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
mdav1s
Contributor
Contributor

Hello. This is seen in the ESXi host web UI. Thank you.

0 Kudos
mdav1s
Contributor
Contributor

Hi results from the command is as follows:

esxcli storage san fc list
Adapter: vmhba1
Port ID: 010200
Node Name: 20:00:00:90:fa:7f:37:04
Port Name: 10:00:00:90:fa:7f:37:04
Speed: 8 Gbps
Port Type: NPort
Port State: ONLINE
Model Description: IBM Flex System FC3052, 95Y2377 2-port 8Gb FC Adapter
Hardware Version: 31004549
OptionROM Version: 5.13x4
Firmware Version: 2.02X11
Driver Name: lpfc
DriverVersion: 11.4.33.25-14vmw

Adapter: vmhba2
Port ID: 000000
Node Name: 20:00:00:90:fa:7f:37:05
Port Name: 10:00:00:90:fa:7f:37:05
Speed: 8 Gbps
Port Type: NPort
Port State: ONLINE
Model Description: IBM Flex System FC3052, 95Y2377 2-port 8Gb FC Adapter
Hardware Version: 31004549
OptionROM Version: 5.13x4
Firmware Version: 2.02X11
Driver Name: lpfc
DriverVersion: 11.4.33.25-14vmw

This is a dual port card on a blade and showing the correct WWPNs. However ESX UI is showing very different Port World Wide and Node Wide names for both vmhba's - It is showing the same values below for both:

Port Worldwide Name: 11:52:92:21:27:28:47:78:75

Node Worldwide Name: 23:05:84:36:31:89:16:25:73

Thank you.

0 Kudos
a_p_
Leadership
Leadership

This looks like a GUI formatting issue, where the WWNs are converted to/displayed as decimal values, and - in addition to this - the last digit is cut off ...

hex: 1000 0090 FA7F 3705
dec: 1.152.922.127.284.778.757

hex: 2000 0090 FA7F 3705
dec: 2.305.843.631.891.625.733

André

e_espinel
Expert
Expert

Hello.
I have worked a long time with IBM Flexsystem and now Lenovo Flexsystem equipment, when there are problems with the HBA in some cases this is reflected in the change of the WWN by a totally different and out of the expected format either Emulex or Qlogic.


Another point of control would be in the FC Switch, entering the GUI of the switch and verifying in Name Server, where the list of the connected ports with their respective WWN should appear.


If you need to use the WWNs to configure in the FC Switch or in some storage you must use the ones indicated in the CLI and that follow the Emluex 10XXX format.


You could think about updating the HBA Firmware, but you have to verify the compatibility of both Hardware (HBA, Switch, Storage) and Software (HBA Driver and Firmware ESXi 6.7).

If you have problems with the HBA, i.e. no communication or intermittent connection, you should think about changing the HBA.

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
mdav1s
Contributor
Contributor

Thanks Enrique.

The wwpn's in the UI appear to be in HEX format which is strange. Volumes mapped to the original WWPNs reported by the command line are visible to the host and the UI, and are accessible. 😉

Tags (1)
0 Kudos