drookie
Contributor
Contributor

ESX 6.5 is unable to format a partition when installing on iSCSI.

Hi.

Recently we encountered an issue with ESX 6.5: it's unable to format the partition when installing onto an iSCSI disk (using Itnel boot agent disk and iSCSI boot). The 6.0 version installs onto the same disk just fine, so right now we are installing 6.0, and then upgrade the installed ESXes to 6.5. The installer is saying: "Unable to successfully execute 'tryFormatDevice' after 3 tries. Installation cannot continue."

esx-6.5-pic2.jpg

Has anyone seen this ? I'll apreciate any ideas on how to solve this.

4 Replies
mfarell31
Contributor
Contributor

I had this issue earlier this evening and it was a painful battle to resolve - and if I'm being totally honest, I'm still unsure what precisely resolved it as I got fed up and changed 10 things at once.

All this to say, take the "fix" below with a grain of salt...

-> Attempt 1, all controllers enabled using Dell OEM image  -> same error as OP
-> VMWare factory 6.5a ISO -> no change
-> remap LUN on id1 0 -> no change
-> format LUN using ESXi partedutil (alt-f1 shell after failure) -> no change
-> format LUN DOS using gparted -> no change

-> Disable all unessary oproms, leaving on Qlogic card -> no change
-> Disable PERC raid controller in bios, at this point I accidentially booted  the wrong installer from my SD card: ESXi6U2 installer . To my surprise, the OS/boot drive formatted/partitioned and ESXi was successfully installed
     -> Did not boot into 6U2, i immediately booted the VMWare 6U5 installer and selected the clean install option (I believe its labeled "do not preserve")

Server: Dell PowerEdge M630 (bios v1.2.5, firmwar 2.20.20.20)

OS disk: 8GB fiber-channel LUN - id0
Data disk: 1TB fiber-challen LUN - id1
CPU: 2x Xeon 2643v3
RAM: 128GB DDR4
RAID controller: PERC H730 Mini (firmware 25.3.0.0016, driver: 6.910.18)
2xDell 240GB SAS SSD (raid1)

NIC1: BRCM 10GbE 2P 57810s bNDC
NIC2: Intel(R) Gigabit 4P I350-t Mezz
HBA: QLogic Fibre Channel Adapter (firmware: 03.22.07

Hope this helps,

Mike

M.F.
0 Kudos
apala917
Contributor
Contributor

Had the same issue when trying to install ESXi 6.5 Update 1 on external storage setup on NetApp. It turned out that issue was due to LUN size of 8G, after increased the size to 11G, we could install the 6.5 Update 1 without any issues.

Nick_Andreev
Expert
Expert

If nothing helps, open a support ticket with VMware. Because who knows, maybe you've run into a bug and you're just wasting your time trying to find a workaround.

---
If you found my answers helpful please consider marking them as helpful or correct.
VCIX-DCV, VCIX-NV, VCAP-CMA | vExpert '16, '17, '18
Blog: http://niktips.wordpress.com | Twitter: @nick_andreev_au
0 Kudos
LAB201110141
Contributor
Contributor

Had same error on an 8GB LUN.

Extended to 16GB and installation completed successfully.