NCC1470
Contributor
Contributor

ESX 4 no more kickstart from harddisk: ks=hd:sda1/ks.cfg ?

Jump to solution

Hi,

I am running a scripted install for 3.5.0 by placing the kickstart file on a "disposable" FAT partition and boot the installation with:

label text kernel /pxeboot/vmlinuz append initrd=/pxeboot/initrd.img text ks=hd:sda1/ks.cfg default text

...I was trying to install ESX 4 the same way but the kickstart file does not get read!

The installation guide is inconsistent here it gives: Default installation script, FTP, HTTP/HTTPS, NFS, USB flash drive (what reads for me as ks=hd...), Local disk

but only this kickstart locations for the boot: ks=cdrom:, ks=file://<path>/ks.cfg, ks=ftp://<server>/<path>/ks.cfg, ks=http://<server>/<path>/ks.cfg, nfs=nfs://<server>/<path>/ks.cfg

Any ideas?

Max

Tags (3)
0 Kudos
23 Replies
vsu
Contributor
Contributor

Even better, if you are using Syslinux >= 3.05 (released in 2005, so you most likely have a recent enough version), you can specify multiple filenames in the initrd=... option:

initrd=initrd.img,extra.img

So you can keep an unmodified initrd.img, and store your modifications in a separate cpio.gz file.

0 Kudos
jameskuhlke
Contributor
Contributor

Would you be kind enough to share you vmesx.sh file?

0 Kudos
TaupoJohn
Contributor
Contributor

Hi James - there seem to be a few variations now, but the one I used is basically the one in Max's post earlier in this thread.

rgds, John B
0 Kudos
rt7500
Contributor
Contributor

James,

Here is a link to my install instructions and ks.cfg.

http://communities.vmware.com/message/1323913#1323913

Ryan

0 Kudos