Dramatic Low bandwidth ESXi 4.1 U1

Hi everyone,

I'm in the process of installing a new home server.
I'm working in IT, and my goal is to be able to reproduce some case study, and home storage.
In that approach I choose to install Freenas 8 RC4 x64
My problem is that i have a very very VERY slow bandwidth from my Win7 laptop in wireless or wired, same result, about 300Kb/s
yes kilo ....!!!!!!
I'm not new to Vmware technology, but i'm not an ESXi expert, far from that ...

I'm using a french provider box (Freebox) as 100Mb switch.

This is my hardware:
asus P7H55M-PRO
Intel i5 650
8 go RAM
Intel Pro /1000PT PCI-E NIC
(cause the integrated Realtek is not HCL)
3x1TB Samsung F3
1x40G Kingston SSDNow

I've been through various test, which lead my to think that the problem comes from my ESXi 4.1u1.
indeed, an installation of freenas as main OS on USB stick give me around 20Mb/s
the Freenas config for this is then the reference one:
3*1TB in ZFS, configured in RAIDZ (RAID-5 like)
a ZFS dataset of the whole space, shared with CIF
CIFS configured, with no permission set (anonymous)

Here is my insallation.
I'm using Esxi 4.1u1, on a 4G CompactFlash, from a USB multiCard Reader.
My SATA drives are in AHCI mode.
I use the 40G SSD as Datastore.
I made from Ssh console, the 3 1TB HDD as RDM (with the vmkfstool command)
So i can add the vmdk files i created into my Frenas VM.
I changed several times the config in Freenas:
ZFS or UFS, RAIDZ or Stripe or mirror, doesn't change anything

As I was having trouble with the network :
    could not get the DHCP offer from the DHCP server
    wasn't able to configure the interface from the CLI menu
    I could assign a static IP from the shell (via ipconfig)
    and then it was working fine
I was guessing that the vmware tools were not present, but they are (v8.7.0.3046 build 313025)
(I had a doubt on that this morning so i installed freenas x86 on my Vmware Workstation and is found this version of vmware tools,
so it is not the same version of freenas and not esxi, but i guess i make not difference, if the freenas team preinstalled the vmware tools)

Beside that i tried another NAS distribution, Openfiler, which is not BSD based but linux,
I did not had trouble with the vmware NIC, and I made an LVM RAID-5 config, same result around 300Kb/s

Then i thought it could be the RDM HDDs,
after moding my oem.tgz to be able to use the JMicron PATA port of my asus motherboard,
I pluged an old IDE drive to use as datastore, and i configured a Passthrough of the intel SATA controler.

i reinstalled Freenas, and then was able to access my SATA drives directy from it without using a vmdk file.
same result .....

If anybody could enlight me, it would be very nice,
maybe there are some basic troubleshooting to do ??
could it be the intel H55 controler ? it is not in the HCL list, but it's a clone of the ICH10 as i understand, and anyway it is well detected by ESXi
as the "Ibex Peak" controler (lspci command), and i can see the drives in the vSphere client.

I now i'm lost .... ^^
I did not try to install a windows VM for testing transfer rate, but i think it's gonna be my next step.
In last resort i could try Ubuntu Server with KVM, but i really like the Vmware environment...

(other thoughts : ...
I first installed Win7 and Vmware Server on this hardware, and Freenas was working a little better when transfering from my laptop to it
with the 3 HDD in Raw mode,
But the issue was already present when transfering from the Win7 Host to the Freenas Guest,
in this scenario i had a 1TB external USB HDD connected,
transfering to the guest freenas using the 3 1TB HDD onboard SATA, with CIFS)

Many thanks for helping me out.


0 Kudos
13 Replies

nobody have a clue ?

0 Kudos

I would try a network tool like iperf to test network performance from your VM to a test machine.  The results should either confirm or eliminate the network as the issue.   The storage in your case won't be great, but it shouldn't be that slow either.  I would also try changing the virtual NIC type in the VMs as this can have an impact on performance.


Thanks for the reply,

I'm using e1000 at the moment, and i have VMXNET2 available I guess,

Do you think the vmware tools could have an impact ?

do i need to reinstall them to use the new NIC ?

0 Kudos

Ideally you should use the latest VMware Tools version.

If you change the NIC type you'll have to update the guest OS config.

0 Kudos

Ok thanks i'll try that tonight.

infact i already tried to change the NIC earlier in the process, but i couldn't make it work,

finaly i came back to e1000,

my main problem is in fact mainly related to my limited knowledge of FreeBSD, but i guess i'm going to install a simple debian for testing.

Thanks again

0 Kudos


Here are my test of last night, i wish i could do more, but didn't not have enough time ^^

First test :

I ran an iperf test with various settings what i could learn is:

When Freenas on ESXi is server

Win7 wireless Client

--> approx 400 KBytes/s Max

When Win7 is server

Freenas is client

--> approx 2.5 MBytes/s

as i'm in 802.11G so 54Mbps, 2,5 or 3 MB/s is correct.

So basicaly it's working in one way, not the other.

I ran the same test with a WinXp wireless too, same result.

Second test:

i wanted to ran the same kind of test with a debian, as freeNAS already has a version of the Vmware tools preinstalled,

i thought it could be helpfull to test with a blank system, and not customized.

I couldn't install Debian, well i could if i would have set a static IP address, here was the problem:

Debian could not receive any DHCP Offer from the DHCP server, the DHCP server is my FreeBOX (internet box from my provider)

The DHCP works fine ofcourse.

I had the same problem with FreeNAS at the begining, but setting a static IP works fine.

My home network is very simple:

The freeBOX for the internet acces, DHCP server.

2 DHCP reservation for my laptop and my ESXi

ESXi only has 1 NIC,

my laptop is

So i ran wireshark to check what was going on

the virtual MAC for debian send a broadcast DHCP REQUEST

the freeBOX send a ARP for ..... which is an ip that does not exist on my network ... i guess it has it in its arp cache, but i could not reboot it at that time

Then i see a RARP from debian virtual MAC to itself, meaning debian is looking for it's own IP, which doesn't exist as there were no DHCP Offer from the FreeBOX.

there is some strange behaviour with this, before looking forward, I would like to have some enlightment about the vSwitch of my ESXi.

what are the best practice when only one NIC is available ? out of the box i have the management network getting the DHCP from the freeBOX, and the VM Network linked to the same NIC. the vSwitch detect the ip range as , again seems strange for me as it is not a range.

in the end i did not install debian to test iperf, but i'm guessing the problem lies there....

PS: i also tried to change from E1000 to VMXNET3, but debian could not detect any NIC when using this one.



0 Kudos

I had a similar problem but not with a FreeNAS box.

The problem was wrong network configuration on the ESXI machine.

I have two ESXI servers. 1: 3.5 u5 and another 4.1.

The box with the 3.5 server had a very low bandwidth to any other network resource on the network but inside the box I received full 1Gbps.

After about a week of solution tracking it came to me to check the network configuration of the ESXI machine. my DNS suffix and default gateway were wrong. after fixing that problem was solved and bandwidth between this machine to any other network resource became normal - including a standalone FreeNAS box.

Hope it may help you.

0 Kudos

Hi Thanks for your reply,

As i'm in a home network, I don't have any domain.

So by default (DHCP) I had the right DNS (from my provider) the only thing is the hostname, which is then ESXiName.localdomain

but beside that everything was ok.

My concern is to try first to remove the embeded vmware tool, to install the latest, or even open vm tools.

but i have no idea how to do that on freenas

i you have clue .... i'll be very greatfull


0 Kudos

To easily rule out network problems, if you have some free space on the ESXi host, you could install a Windows/Linux client and test the transfer rate inside the host, if transfer rate suits the drives speed so you probably have a problem with your network interface hardware/configuration.

As of uninstalling open-vmware tools from FreeNAS, cant help you with that. Did you try opening a thread on FreeNAS forums?


0 Kudos

Yeah that was my plan with a Debian, as i said earlier, but as i got some network problem with debian aswell, i'm pretty sure the problem is network related, and ESXi related.

concerning the Freenas forum, yeah that was the plan, but as i got the same behaviour with OpenFiler with is linux based, i thought i was useless and better to post here.

i'm gonna try to finish the debian install, we'll see Smiley Happy, and maybe with another DHCP server

0 Kudos

okay now debian just go the DHCP out of the box, i did nothing...

I LOVE IT science ^^

keep you posted

0 Kudos

you know that sometimes you're looking too hard, and too deep, and the answer is often just ... "reboot"

After rebooting my freeBOX from my provider everything is working very fine ... 2,5 meg in wireless 11meg wired.

very strange, but now i know this device is not reliable and the WRT54G that lies somewhere in my flat is going to have a second life Smiley Happy

Thanks all for you help

0 Kudos

Glad you made it out eventually.

0 Kudos