VMware Cloud Community
ladymixy
Contributor
Contributor

Difficulty getting vSphere Client to update - ESXi 4.1

Background -

We have two Dell R710's which are running fine on ESXi 4.0 Update 1. We've been using the free vSphere client that was downloaded at the time of installation (December, 2009). Vsphere Client 4.0.0 Build 208111, and VMware ESXi 4.0.0 Build 208167.

We just got in another Dell R710 the other day, and I noticed that ESXi 4.1 is available. Being the fearles and trusting type that I am, I downloaded that, and installed it on the server.

It has its management IP fine. I can connect to it by browser in order to see the welcome screen which includes links on the right for vsphere command line.

But when I click on the link for Downloading the vSphere Client, it tries to send me to a link ending in VMware-viclient-all-4.1.0-258902.exe ... but my Sonicwall blocks it saying that the file contains the Bumat_7 trojan. Exact message: "This request is blocked by the SonicWALL Gateway Anti-Virus Service. Name: Bumat_7 (Trojan)"

So alternatively, if I launch the vSphere Client that I already had (version 4.0) and try to connect to the new server, I immediately am prompted to "run the installler," which I try to do, and end up getting errors. Have tried installing on Windows 7 and on Windows 2003, similar errors. Also tried to "save the installer" and run that, but I get an "illegal instruction" message.

At this point, I'm stuck. Anyone else seeing odd stuff like this?

Powering off the server for the weekend and will deal with it on Monday! Cheers!

Reply
0 Kudos
3 Replies
RvdNieuwendijk
Leadership
Leadership

I tried what you did, save the installer from the link on the ESXi 4.1 servers webpage and I had no problem downloading and installing it on a Windows 7 Ultimate 64-bits PC. You might have a problem with the SonicWALL Gateway Anti-Virus Service. I run Avira AntiVir Personal antivirus software.

Regards, Robert

Blog: https://rvdnieuwendijk.com/ | Twitter: @rvdnieuwendijk | Author of: https://www.packtpub.com/virtualization-and-cloud/learning-powercli-second-edition
ladymixy
Contributor
Contributor

Thanks for the info! I am getting the same thing today, so I also posted over on the SonicWALL community. Will open a ticket with SonicWALL if necessary.

Reply
0 Kudos
ladymixy
Contributor
Contributor

Opened an incident with Sonicwall, who confirmed that it was a "false positive" hit. They adjusted their definition files, and we're good to go. Thanks everyone!

Reply
0 Kudos