sjkoehler
Contributor
Contributor

Desparate to recover files from within VMDK, praying someone can help

I'll do my best to not make this painfully long to explain.

Desktop ESX setup using (2) 2TB Sata drives, running fine for about a year. A key VM was a Win2k12 with a 1.2TB (I think) drive that hosted my file share with important files, that stupidly were not backed up elsewhere.

I suspected one 2TB drive hosting the Win2k12 VM was starting to go bad, so I rushed to copy my share contents (about 800GB) to a USB drive. I got everything but one folder before the VM froze, but it's a folder I'd really like to have back. I tried:

  1. Several times to repower up the VM, and it would always hang at 95%,
  2. Tried taking another VM and attaching the VMDK, which failed with an error I don't recall exactly what the message was.
  3. Tried to use Vsphere client to copy the VM files over to the other drive/datastore, which got some stuff over but eventually failed (after about 22 hours), including 1 of the 3 vmdk files. The other 2 vmdk files and a few other files remained on the suspected failed drive.
  4. Used DiskInternals VMFS Recovery, with both Sata drives connected to a Sata to USB converter kit, using my laptop, to transfer VMDK files to an external 3TB drive. The files were:
      VMWin2k12DC001-flat.vmdk (1.29TB)
      VMWin2k12DC001-000001-delta.vmdk (346MB)
      VMWin2k12DC001-000002-delta.vmdk (745GB)
  5. Once I had the 3 files, I tried using the vmware-mount utility to mount the drives hoping I could extract the data. I got the error "Unable to mount the virtual disk. The disk may be in use by a virtual machine, may not have enough volumes or mounted under another drive letter. If not, verify that the file is a valid virtual disk file." Does this likely mean my virtual drive is toast?

I guess I should note that I thought the file name of the primary (non delta) vmdk didn't have the word "flat" in it when looking at the files from Vsphere client browsing the datastore, dunno if that's normal when transferring the files to a windows drive format, or if it has any significance.

I'm assuming I lost my data, but wanna exhaust everything possible.

A) Should I only need the 3 vmdk files above for vmware-mount to work, or are there special command line parameters I use for snapped/multiple disks when using vmware-mount?

B) Considering I've further crippled myself by splitting the VM files up on each 2TB disk, is there anything possible I can do to try and get this drive mounted?

I started to try and upload the files I got off the bad drive using DiskInternals VMFS Revovery to the good drive/datastore, but ETA was like 2+ days (gigabit nic on ESX box and laptop and CAT6 cable). Wondering if I should just suck it up and try this.

I would be forever grateful if anyone has some ideas for me.

Thx much in advance...

0 Kudos
1 Reply
admin
Immortal
Immortal

Looks like your VM was running on snapshot files. What I would recommend is trying to fix the VM. This is what your VM would look like VMWin2k12DC001-000002-delta.vmdk is the child snapshot file of VMWin2k12DC001-000001-delta.vmdk and then the latter is pointed to you base disk VMWin2k12DC001-flat.vmdk . If you want your VM to be fine, I would recommend to clone the VM. believe me it would take time to create the clone but ultimately it will complete. Cloning would depend on your network bandwidth since it is NFC.

0 Kudos