GreggHudson
Contributor
Contributor

Dell Customized VMware ESXi 5.1.0 update VMware ESXi 6.5?

I have a Dell PowerEdge R620

Vsphere states that "You are running Dell Customized VMWare ESXi 5.1.0 (VMKernel Release Build 799733)"

However, it also states that my Vmware ESXI is Version:6.0.0 Update 3 (Build 5572656)

I tried to update to the latest VMWare 6.5 version, but I receive errors during the install.

Question 1; How can I be running both a Dell ESXi and a VMWare ESXi?

Question 2: What do I need to do to get the latest 6.5 version installed?

pastedImage_2.png

0 Kudos
12 Replies
daphnissov
Immortal
Immortal

You're currently running ESXi 6.0, but this host was originally installed via a Dell-customized ESXi 5.1 image.

As for the errors you encountered, we need more information about what messages were displayed, how you attempted the upgrade, what commands you used, etc.

0 Kudos
GreggHudson
Contributor
Contributor

[root@lej07esx:~] esxcli software profile update -d /vmfs/volumes/datastore1/ESXUpdates/ESXi650-201712001.zip -p ESXi-6.5.0-20171204001-standard

[DependencyError]

VIB Emulex_bootbank_scsi-be2iscsi_4.2.324.12-1OEM.500.0.0.472629 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB QLogic_bootbank_net-qlcnic_5.0.750-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB Emulex_bootbank_scsi-be2iscsi_4.2.324.12-1OEM.500.0.0.472629 requires com.vmware.iscsi_linux-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_net-bna_3.1.0.1-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB Emulex_bootbank_scsi-be2iscsi_4.2.324.12-1OEM.500.0.0.472629 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB QLogic_bootbank_scsi-qla4xxx_624.01.43-1OEM.500.0.0.472560 requires com.vmware.iscsi_linux-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB VMware_bootbank_net-qlge_2.0.0.54-1vmw.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB QLogic_bootbank_net-qlcnic_5.0.750-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB VMware_bootbank_net-qlge_2.0.0.54-1vmw.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB QLogic_bootbank_scsi-qla4xxx_624.01.43-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_net-bna_3.1.0.1-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_scsi-bfa_3.1.0.1-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB QLogic_bootbank_scsi-qla4xxx_624.01.43-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_scsi-bfa_3.1.0.1-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

Please refer to the log file for more details.

This exact same command and ESXi650-201712001.zip worked perfectly on all my non-Dell-customized Dell PowerEdge R610's

0 Kudos
daphnissov
Immortal
Immortal

What is the output of the following command.

esxcli software sources profile list -d /vmfs/volumes/datastore1/ESXUpdates/ESXi650-201712001.zip

0 Kudos
GreggHudson
Contributor
Contributor

Name Vendor Acceptance Level

-------------------------------- ------------ ----------------

ESXi-6.5.0-20171201001s-no-tools VMware, Inc. PartnerSupported

ESXi-6.5.0-20171204001-standard VMware, Inc. PartnerSupported

ESXi-6.5.0-20171204001-no-tools VMware, Inc. PartnerSupported

ESXi-6.5.0-20171201001s-standard VMware, Inc. PartnerSupported

0 Kudos
daphnissov
Immortal
Immortal

Ok, so you're declaring a valid profile. The reason you're getting those dependency errors has to do with the outdated drivers, for example.

Brocade_bootbank_scsi-bfa_3.1.0.1-1OEM.500.0.0.472560

This is a driver certified for ESXi 5.0 and uses a driver architecture system that is not present in ESXi 6.5. So you'll need to do one of two things if you wish to upgrade.

  1. Verify none of your devices are using any of the drivers mentioned in the output from the failed esxcli command. If none are, remove the VIBs listed and reboot the host.
  2. Upgrade the drivers to more recent versions supported on 6.0 that use the native kernel driver framework. This will also necessitate a reboot.
0 Kudos
GreggHudson
Contributor
Contributor

How do I "remove the VIBs listed"?

0 Kudos
daphnissov
Immortal
Immortal

esxcli software vib remove -n <name>

0 Kudos
GreggHudson
Contributor
Contributor

Up[date:

I was able to update to the Dell version 6.0 ESXi

VMware-VMvisor-Installer-6.0.0.update03-6921384.x86_64-DellEMC_Customized_A07.zip

Now, when I try to update to 6.5, I only have 4 errors, rather than the dozen I had before:

[DependencyError]

VIB Brocade_bootbank_scsi-bfa_3.1.0.0-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_net-bna_3.1.0.0-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_net-bna_3.1.0.0-1OEM.500.0.0.472560 requires vmkapi_2_0_0_0, but the requirement cannot be satisfied within the ImageProfile.

VIB Brocade_bootbank_scsi-bfa_3.1.0.0-1OEM.500.0.0.472560 requires com.vmware.driverAPI-9.2.0.0, but the requirement cannot be satisfied within the ImageProfile.

Seems I am using these drivers?:

[root@PEN02ESX:~] esxcli software vib list | grep Bro

net-bna 3.1.0.0-1OEM.500.0.0.472560 Brocade VMwareCertified 2015-12-01 

scsi-bfa 3.1.0.0-1OEM.500.0.0.472560 Brocade VMwareCertified 2015-12-01

pastedImage_0.png

0 Kudos
daphnissov
Immortal
Immortal

In this case, those two drivers are still preventing you from further upgrading. The "500.0.0" portion still refers to the ESXi 5.0 build for which they were designed. So, like I said before, ensure you don't have any devices using those. If not, go ahead and remove them and you should be able to punch up to 6.5.

0 Kudos
nponeccop
Contributor
Contributor

I found various compatibility documents for Dell servers. Please check if your server is supported:

VMware vSphere 6.5.x on Dell PowerEdge Servers Compatibility Matrix

If it's not then you are out of luck as the necessary drivers from Dell don't exist. In this case you should apply the latest 6.0 patch

esxcli software profile update -p ESXi-6.0.0-20180104001-standard \
-d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

And this configuration is still supported and up to date, but you obviously don't have 6.5 features.

A simpler way to check is to see the compatible systems of VMware ESXi 6.5 Driver Details | Dell US

HP doesn't develop new drivers for servers earlier than Gen9 any more, even for 6.0, so I wonder if Dell followed the suit.

0 Kudos
GreggHudson
Contributor
Contributor

But how can I tell if anything is using those particular drivers?

net-bna                        3.1.0.1-1OEM.500.0.0.472560          Brocade  VMwareCertified   2015-11-30

scsi-bfa                       3.1.0.1-1OEM.500.0.0.472560          Brocade  VMwareCertified   2015-11-30

0 Kudos
SupreetK
Commander
Commander

'bna' is a NIC driver and 'bfa' is an FC adapter driver. Run the commands <esxcfg-nics -l> and <esxcfg-scsidevs -a> to know the drivers being used by the NIC and storage adapters, respectively. If these are not listed in the output of the above commands, they are not being used.

Please consider marking this answer as "correct" or "helpful" if you think your questions have been answered.

Cheers,

Supreet

0 Kudos