Datastore not mounted after reboot of ESXi5.5

Current configuration: 

HP Proliant ML350e with Smart Array card

ESXi 5.5 from HP Custom ROM

Boot from 4GB SataDOM

Two logical arrays on Smart Array (LUN 0/Datastore 1 and 1/Datastore 2)

Windows Server 2012 (DC) installed on Datastore 1

Windows Server 2012 (TS) installed on Datastore 2

I have installed a new server from the HP custom ROM and on reboot Datastore 1 is not mounted.  The datastore can be found then mounted by adding storage and keeping the signatures.  Datastore 2 is mounted on boot and loads the VM. 

Searching found the the following KB article, but that did not resolve my issue:

11 Replies
Hot Shot
Hot Shot

You need tp perform a rescan for the storage in ESXI .

You can perform a rescan in these ways:

Note: Performing a rescan does not cause a service interruption.

Using the VMware vSphere or VI Client to perform a rescan

To rescan using the vSphere or VI Client:

  1. Log in to the client and select an ESX/ESXi host in your inventory.
  2. Click the Configuration tab.
  3. Click Storage Adapters.
  4. Click the Rescan link.
  5. Click OK to begin the rescan.

    Note: This performs a rescan of every installed Host Bus Adapter (HBA), regardless of the HBA that is selected in the Storage Adapters view.

    The progress of the rescan can be monitored from the ESX/ESXi host console in the /var/log/vmkernel (for ESX hosts) or/var/log/messages (for ESXi) logfiles.

Note: The Rescan in the VI Client, by default, combines the rescan for new LUNs (and removal of retired ones) with the detection of new VMFS data stores, depending on which check boxes are selected when the rescan is initiated. The rescan and datastore detection are asynchronous processes. As a result, the detection process for new data stores may complete before the detection process for new LUNs is complete. You may need to perform the rescan twice if the newly added LUN has a VMFS data store on it, or perform an HBA rescan and VMFS rescan in separate tasks. You may select either or both of the two to be performed, per a modal dialog box when initially beginning a rescan.

Let me know if this helped you out please

Best regards

Yours, Oscar

0 Kudos

Thank you for your reply. 

Rescaning the adapter and Adding Storage will mount the Datastore.  The issue is that upon every reboot the Datastore1 is not mounted.  I Rescanned the adapter (twice as detailed), Added Storage (finding and mounting the Datastore), shut down the VMs and powered down the server.  Upon reboot Datastore1/LUN0 was not mounted.  A repeat of the Rescan/Add Storage process did mount the Datastore1.  After another reboot, the same Datastore1 was not mounted. 

The issue remains that upon a reboot the the server Datastore1 is always not identified and mounted automatically.  Datastore2 does mount automatically.  Manually Adding Storage will mount the Datastore and allow the VM to load. 

0 Kudos

After reboot, can you check UUID of datastores

Before Reboot datastore1 UUID

After Reboot datastore2 UUID

This is very weird behavior....If you can check vmkernel logs...any error message populates during datastore mount..

Thanks -A Read my blogs:
0 Kudos
Hot Shot
Hot Shot

I had this same problem and tried various things, different builds (as the ESXi environment was on an SD card).

So first thing I thought was that I might need a customized ESXi image as  there appears to be some problems with tha standard ISO for ESXi5.5 U1 installation on HP servers. I've seen ythis before with previous versions of ESXi 4 on HP kit and so you may have to use the customized HP ISO.

The ISO to try is


The ISO for download can be found here

This made no difference and the local storage would still continue to drop on reboot but could be readded. I then found some stuff alluding to the fact that the standard VMware version overwrites the OEM drivers but again this proved to make no difference.

I finally resignatured the disk and kept the data and this proved successful in my case.


Same problem and solution here (but with 5.5 U2):

Select assign new signature / uuid instead of keeping the old one.

0 Kudos

we had the same problem on ESXİ 6.0 . Steps below worked for us.

  1. I manually added the datastores again, then removed the VMs from inventory.
  2. Reboot.
  3. Re-add datastores, specifying "Assign new signature"  Takes a few seconds for each.
  4. Re-add the VMs using Browse datastore, and adding the .vmx
  5. Reboot.  Datastores are there.  YES.
  6. One VM wouldn't start because it had a second hard disk which was on the second datastore.  Edit the VM, remove the second HDD, re-add it, specify an existing HDD.
  7. When starting the VMs, I was asked if I copied or moved them.  Selected "Moved".
  8. Added VMs to Automatic Startup, rebooted once more for good measure.  All good.

I know this is a bit of an old thread but thought I'd recommend the previous post as a fix.

I had the same problem on a server (ESXi 5.5) that I used for testing/staging VMs so I lived with it. However after several months I decided to try to fix it. I gOOgled lots and this was the method that worked for me. I post this belatedly just in case anybody else does what I do and happen upon this thread.

Well done mcblind‌.

0 Kudos

Hi BazM, I have the same problem with 3 Host ESXi 5.5.0 (1623387) and IBM Storwize V3700 iSCSI and I would like to know how you could solve it.

Thank you.

0 Kudos

Hi ,

Please check the firmware and driver version of controller , if it is outdated one update to latest one .

RAJESH RADHAKRISHNAN VCA -DCV/WM/Cloud,VCP 5 - DCV/DT/CLOUD, ,VCP6-DCV, EMCISA,EMCSA,MCTS,MCPS,BCFA Mark my post as "helpful" or "correct" if I've helped resolve or answered your query!
0 Kudos

Similar issue - 6.0u3 esxi host at remote office worked fine for a couple years, today after a power outage the local datastore disappears and vm's are 'inaccessible' after each reboot and "the esxi host does not have persistent storage' is displayed. The local sata hard drive is still present in the devices and the datastore reappears after manually initiating a refresh or rescan of storage. Datastore renaming or unmount/mount were tried after removing vm's from inventory and dropping to maintenance but it still disappears after reboot.  Datastore and vm's can be browsed + inventoried after the refresh or rescan.  SMART health status for the drive is OK.  Error below is thrown during the add storage screens with no option to resignature the datastore.  Any way to forcefully resignature this or other suggestions to try?  Uhwanted last resort I'm considering is deleting the datastore and creating a new one.  Thanks


Update: applied bandaid to the problem for now via /etc/rc.local.d/

vm still wouldnt power on automatically during startup with only the first two lines even though additional startup delay was set and datastore now populates, has to be started up like this from the or manually

esxcli storage core adapter rescan --all

vmkfstools -V

sleep 90s; vim-cmd vmsvc/power.on 1

exit 0

0 Kudos


solved the described issue here too.


(ESXI 5.5.0 + hpTools @ HP G8 Microserver )

0 Kudos