digitalnomad
Enthusiast
Enthusiast

Datastore / Disk latency problems with HP ProLiant G7 - HP Smart Array P410i controller " WARNING: LinScsi: SCSILinuxAbortCommands:1843: " and "Lost access to volume" (Still an issue with hpsa 5.5.0.114-1OEM )

After updating a mixture of G7, G8 and G9 VMHosts to 5.5 update 3a and Cookbook release September 2015 (SPP JUN 15). I started having host errors specifically on my G7 hardware. One host went so far as to disconnect from VCenter.

I went the full boat update on the OS to bring it fully in line with HP's recipe. This was the first time hitting drivers in quite a while. So when the first errors started coming in, I immediately suspected the HPSA v106 ( Version:5.5.0.106-1OEM ) which was updated from v50 ( Version:5.5.0.50-1OEM)

VCenter is reporting errors

Lost access to volume 56424481-7f094eb0-8ee6-

80c16e6e15e0 (VMHost_local) due to

connectivity issues. Recovery attempt is in

progress and outcome will be reported shortly.

info 2/2/2015 9:00:45 AM (VMHost_local)

VMKernel.log was reporting some conflict's with claim rules between PowerPath and the NMP for the local disk but that was cleared.

2015-11-29T07:53:04.162Z cpu22:33327)WARNING: LinScsi: SCSILinuxAbortCommands:1843: Failed, Driver hpsa, for vmhba1

Hostd.log

2015-11-30T19:37:48.614Z [248C4B70 info 'Vimsvc.ha-eventmgr'] Event 1820 : Lost access to volume 4ffd89b4-760e9689-81e3-e83935a81a45 (gldpiesx002_local) due to connectivity issues. Recovery attempt is in progress and outcome will be reported shortly.

2015-11-30T19:37:48.615Z [248C4B70 info 'Vimsvc.ha-eventmgr'] Event 1821 : Successfully restored access to volume 4ffd89b4-760e9689-81e3-e83935a81a45 (gldpiesx002_local) following connectivity issues.

I opened tickets with both HP and VMWare

VMWare came back with the first fix which was to upgrade the hpsa driver(hpsa 5.5.0.114-1OEM) which can be downloaded from https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI55-HP-HPSA-550114-1OEM&productId=353. however overnight , the errors returned.

HP has suggested back-revving to 5.5.0.74-1(1 Oct 2014) but from a previous discussion here [ Datastore / Disk latency problems with HP ProLiant DL380 G7 - HP Smart Array P410i controller after ...   ]  I believe that was also a bad version.

I'm going to wander down the road a bit and see where it leads and if necessary go back to the 70 or even 50 release

Comments welcome

Tags (4)
0 Kudos
20 Replies
maaca
Enthusiast
Enthusiast

Thanks for pointing on this version.

ProLiant DL370 G6 with P410i - RAID 5 + spare disk.

SPP 2016.04.0, firmware 6.64

ESXi 6.0 U1b

Running with scsi-hpsa_6.0.0.120 for about 4 hours - no warnings in logs, no latency peaks. 🙂

Let's wait, if it is not causing PSOD in few days...

Correct me if I'm wrong, but what I remember, working version was not released in past 2 years.

0 Kudos