andersom
Contributor
Contributor

Configuring iSCSI Networking

Running esxi 4.1 embedded

I am following the iSCSI SAN configuration Guide.  I have two dedciated physical NICS for iSCSI traffic using software iSCSI initiator.

I have one vswitch created with two iscsi ports, one iscsi port has one adapter active and the other adapter set to unused, did the same for the second iscsi port.

Then it says to bind the iscsi ports for Multiple NICS, is it necessary to do perform this step?  Are there any reasons to do it or not do it?

When I try to bind it with the command in Remote client i get the attached error message

0 Kudos
7 Replies
Monolithic
Enthusiast
Enthusiast

What vendor is your iSCSI storage device? Check with their documentation on VMware setup.  They all should have their own ways to set up redundant multipathing.  I use several Dell/Equallogic SANs and they have their own multipathing script that configures the iSCSI vswitch for you, you just give them IP addresses and the script does the rest.

0 Kudos
idle-jam
Immortal
Immortal

0 Kudos
Chamon
Commander
Commander

When useing PowerCLI for Get-esxcli I create an alias for it

connect-viserver <my ESXi Host> #Not the vCenter server!!

$esxcli=get-esxcli

$esxcli swiscsi nic add -n port_name -d vmhba

Sorry I posted the incorrect syntax in this post. See my newer post for the correct information using PowerCLI

0 Kudos
mittim12
Immortal
Immortal

0 Kudos
unsichtbare
Expert
Expert

I had trouble with the RCLI and vMA once or twice as well. Too many variables between the command and the ESXi server(s) on which the command is acting.

Try Technical support mode to eliminate the possibility of connection/authentication issues between the client, vCenter, and ESXi.

When entering the command, be sure to use the correct vmhba. The software iSCSI initiator is usually vmhba32, but not always!

esxcli swiscsi nic add -n vmk0 -d vmhba32

esxcli swiscsi nic add -n vmk1 -d vmhba32

what this accomplishes is binding all available physical NICs in the respective Port Groups to the respective vmkernel virtual adapters. That's why you marked one NIC per Port Group as unused. Without proper NIC binding, you will not create multiple storage paths.

-J

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/
andersom
Contributor
Contributor

I called Dell yesterday for support and they said VMware vSphere PowerCLI does not not support the command.  Had to enable ssh on host and we used putty and the command worked.  Thanks for all the responses.

0 Kudos
Chamon
Commander
Commander

Here is the relevant portion of the code from the scripts we use. We are using ESXI 4.1 installable not embedded. It is PowerCLI 4.1.1

connect-viserver $vh01

$esxcli=get-esxcli

##Configure Port binding for iSCSI software adapter
#Get the Adapter


$adapter=get-vmhosthba |where {$_.Model -eq "iSCSI Software Adapter"} |select device
$adapter1=$adapter.device
#Get the vmNIC
$vmknic=Get-VMHostNetworkAdapter |where {$_.portgroupname -eq "iSCSI"} |select name
$vmnic1=$vmknic.name
#Bind the adapter to the vmNIC
$esxcli.swiscsi.nic.add($adapter1, $vmnic1)

This works well for us. Our portgroup is named iSCSI so you would need to insert what portgroup name you are using.

0 Kudos