freever
Contributor
Contributor

Configuration issue : No vmkcore disk partition

Jump to solution

Hello,

Is there any solution to disable "Host core dumps cannot be saved" warning on ESXi hosts :

Untitled.jpg

All my target are ISCSI and don't need to configure coredump for ESXi hosts.

Checked the configuration and seems that no partition or network dump configured :

# esxcli system coredump partition list

Name                                    Path                                                        Active  Configured

--------------------------------------  ----------------------------------------------------------  ------  ----------

eui.d832578e6a392c356c9ce9006  /vmfs/devices/disks/eui.d832578e6a392c356c9ce9006   false       false

esxcli system coredump network get

   Enabled: false

   Host VNic:

   Network Server IP:

   Network Server Port: 0

Any help please?

Thanks,

1 Solution

Accepted Solutions
jrmunday
Commander
Commander

Looks like the guy solved it using dump and syslog collector;

VKUMO | Configure coredump & syslog server on diskless ESXi 5.1

Now open up PuTTY connect your host, login as root and run the commands:
# esxcli system coredump network set --interface-name vmk0 --server-ipv4 10xx.xx.xx.xx --server-port 6500
replacing 10xx.xx.xx.xx with your core dump server.
Enable the new setting:
# esxcli system coredump network set --enable true

That’s it, no more warning on your host and when creating a Host Profile for deployment of more hosts these settings will be inherited.

vExpert 2014 - 2018 | VCP6-DCV | http://www.jonmunday.net | @JonMunday77

View solution in original post

0 Kudos
4 Replies
jrmunday
Commander
Commander

VMware KB: Host displays warning: No coredump target has been configured. Host core dumps cannot be ...

vExpert 2014 - 2018 | VCP6-DCV | http://www.jonmunday.net | @JonMunday77
freever
Contributor
Contributor

Thank you

already tried this KB even I am not using host profile Smiley Happy

I tried also to create profile from host that showing the warning and found that Coredump Partition Settings option already deselected .... apply the profile created from host didn't solve my problem.

jrmunday
Commander
Commander

Looks like the guy solved it using dump and syslog collector;

VKUMO | Configure coredump & syslog server on diskless ESXi 5.1

Now open up PuTTY connect your host, login as root and run the commands:
# esxcli system coredump network set --interface-name vmk0 --server-ipv4 10xx.xx.xx.xx --server-port 6500
replacing 10xx.xx.xx.xx with your core dump server.
Enable the new setting:
# esxcli system coredump network set --enable true

That’s it, no more warning on your host and when creating a Host Profile for deployment of more hosts these settings will be inherited.

vExpert 2014 - 2018 | VCP6-DCV | http://www.jonmunday.net | @JonMunday77

View solution in original post

0 Kudos
freever
Contributor
Contributor

Thank you very much.

That solve my problem and no more warning on the host even the IP address used never exist on my network :smileysilly:

Will wait until tomorrow to see if there is any impact on the server than will apply on all server.

0 Kudos