phuz
Enthusiast
Enthusiast

Certificate errors when accessing vSphere web client on 6.5 (Hypervisor)

I am constantly getting the certificate warning in Chrome when trying to access my Home Lab's vSphere web client.  (same warning in IE)

I've tried saving off the certificate and importing it, but it doesn't actually appear to import.  I've spent a few days going through all the links on how to "fix" this and so far nothing has remedied it.

Any help appreciated.

Your connection is not private

Attackers might be trying to steal your information from 192.168.2.4 (for example, passwords, messages, or credit cards).

NET::ERR_CERT_AUTHORITY_INVALID

7 Replies
rcporto
Leadership
Leadership

Are you using the vSphere ESXi embedded host client (https://esxi-ip-or-fqdn/ui) or the vCenter vSphere Web Client (https://vcenter-ip-or-fqdn/vsphere-client)? If using the vCenter vSphere Web Client, check the following VMware KB article: How to download and install vCenter Server root certificates to avoid Web Browser certificate warnin...

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
phuz
Enthusiast
Enthusiast

I have no option to download certificates when going to https://IP/vsphere-client.  I've tried downloading them from the web browser and manually installing them, but they don't appear to stay nor do they work.

0 Kudos
phuz
Enthusiast
Enthusiast

And sorry, I'm using the UI, not the vsphere-client.

0 Kudos
phuz
Enthusiast
Enthusiast

Bueller?

0 Kudos
phuz
Enthusiast
Enthusiast

Still no answers on this?

0 Kudos
akmans
Contributor
Contributor

try adding the address to your trusted sites

0 Kudos
Raj1988
Enthusiast
Enthusiast

Ideally we need to use custom certs .But in case you cannot use custom certs .

Follow VMware Knowledge Base

For ESXi :- Open the UI client , Download the certs and import them to the IE browser and put in to Trusted Root . It should work for both IE and Chrome.

pastedImage_2.png

0 Kudos