rvkrish
Contributor
Contributor

Cannot passthrough 0000:00:1e.2 Serial bus controller: Intel Corporation Device a32a

Jump to solution

I have an Intel Xeon E-2176M processor and I am trying to pass through the GSPI interfaces to the Ubuntu VM. 

The output of lspci for those interfaces is below

0000:00:1e.2 Serial bus controller: Intel Corporation Device a32a
0000:00:1e.3 Serial bus controller: Intel Corporation Device a32b

I have tried esxcli system settings kernel set --setting=disableACSCheck --value=TRUE 

but that did not work. I do not see these devices in the /etc/vmware/pci.ids file so I am not if it is not supported at all. 

Is there a way to add it and have it enabled ? 

 

Some data points

 

vmware -vl
VMware ESXi 6.5.0 build-13932383
VMware ESXi 6.5.0 Update 3

vmkchdev -l | grep "8086:a32[a,b]"
0000:00:1e.2 8086:a32a 8086:7270 vmkernel
0000:00:1e.3 8086:a32b 8086:7270 vmkernel

 

Output from "esxcli hardware pci list" for the two interfaces

0000:00:1e.2
Address: 0000:00:1e.2
Segment: 0x0000
Bus: 0x00
Slot: 0x1e
Function: 0x2
VMkernel Name:
Vendor Name: Intel(R)
Device Name: <class> Serial bus controller
Configured Owner: Unknown
Current Owner: VMkernel
Vendor ID: 0x8086
Device ID: 0xa32a
SubVendor ID: 0x8086
SubDevice ID: 0x7270
Device Class: 0x0c80
Device Class Name: Serial bus controller
Programming Interface: 0x00
Revision ID: 0x10
Interrupt Line: 0xff
IRQ: 255
Interrupt Vector: 0x00
PCI Pin: 0x02
Spawned Bus: 0x00
Flags: 0x3201
Module ID: -1
Module Name: None
Chassis: 0
Physical Slot: 4294967295
Slot Description:
Passthru Capable: false
Parent Device:
Dependent Device:
Reset Method: None
FPT Sharable: false

0000:00:1e.3
Address: 0000:00:1e.3
Segment: 0x0000
Bus: 0x00
Slot: 0x1e
Function: 0x3
VMkernel Name:
Vendor Name: Intel(R)
Device Name: <class> Serial bus controller
Configured Owner: Unknown
Current Owner: VMkernel
Vendor ID: 0x8086
Device ID: 0xa32b
SubVendor ID: 0x8086
SubDevice ID: 0x7270
Device Class: 0x0c80
Device Class Name: Serial bus controller
Programming Interface: 0x00
Revision ID: 0x10
Interrupt Line: 0xff
IRQ: 255
Interrupt Vector: 0x00
PCI Pin: 0x03
Spawned Bus: 0x00
Flags: 0x3201
Module ID: -1
Module Name: None
Chassis: 0
Physical Slot: 4294967295
Slot Description:
Passthru Capable: false
Parent Device:
Dependent Device:
Reset Method: None
FPT Sharable: false

 

Thank you

Ram Krishnan 

0 Kudos
1 Solution

Accepted Solutions
rvkrish
Contributor
Contributor

The solution is to add entries to the /etc/vmware/passthru.map.  Reboot and enable Passthru on the devices on the GUI which now will not be greyed out and reboot again.

These are the 4 PCI Lanes 

0000:00:1e.0 Communication controller: Intel Corporation Device a328
0000:00:1e.1 Communication controller: Intel Corporation Device a329
0000:00:1e.2 Serial bus controller: Intel Corporation Device a32a
0000:00:1e.3 Serial bus controller: Intel Corporation Device a32b

File: /etc/vmware/passthru.map

Add the following 4 entries under Intel.

8086 a328 d3d0 default
8086 a329 d3d0 default
8086 a32a d3d0 default
8086 a32b d3d0 default

View solution in original post

0 Kudos
1 Reply
rvkrish
Contributor
Contributor

The solution is to add entries to the /etc/vmware/passthru.map.  Reboot and enable Passthru on the devices on the GUI which now will not be greyed out and reboot again.

These are the 4 PCI Lanes 

0000:00:1e.0 Communication controller: Intel Corporation Device a328
0000:00:1e.1 Communication controller: Intel Corporation Device a329
0000:00:1e.2 Serial bus controller: Intel Corporation Device a32a
0000:00:1e.3 Serial bus controller: Intel Corporation Device a32b

File: /etc/vmware/passthru.map

Add the following 4 entries under Intel.

8086 a328 d3d0 default
8086 a329 d3d0 default
8086 a32a d3d0 default
8086 a32b d3d0 default

View solution in original post

0 Kudos