Stefan1990
Contributor
Contributor

Cannot mount VMFS datastore without format after Raid5 rebuild

Hello gents,

I have a little tricky issue.

After my Raid5 crash (now is working), ESXi (4.1) cannot mount this raid. I see it on Devices sheet, but when I tried to add this datastore, the only one choice what I have is format this datastore. I have 2TB of files on this raid so I really need to save this content.

~ # esxcfg-volume -l

VMFS3 UUID/label: 4e789053-cf3210d0-9f0f-782bcb2d8f4b/Raid5_02

Can mount: No (some extents missing)

Can resignature: No (some extents missing)

Extent name: naa.6782bcb047c08600215129bf064566cf:1     range: 0 - 2078463 (MB)

It is any chance how I can mount this datastore without format?

Thanks for any reply.

0 Kudos
2 Replies
parmarr
VMware Employee
VMware Employee

Please refer to this KB: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=20466...

Sincerely, Rahul Parmar VMware Support Moderator
0 Kudos
continuum
Immortal
Immortal

For your own good please ignore Rahuls suggestion - that approach may do the final knock-out.
Instead have a look at Create a VMFS-Header-dump using an ESXi-Host in production | VM-Sickbay
and provide a download for zthe dumpfile.
Then I can suggest a safe approach.
Feel free to call me via skype
Ulli


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos