Enthusiast
Enthusiast

Cannot get ESXi 6.5 installer to recognize PCIe SSD drives

I am trying to install ESXi 6.5 on a Dell Precision Workstation.  The workstation is configured with:

  • two 512GB SATA SSD drives
  • four 1TB SSD drives connected to a PCIe card

When I get to the part where it asks where I want to install ESXi, only the two SATA drives are visible.  (There is no Raid involved, the PCIe drives are connected directly to the PCIe card)

As a test, I tried installing Windows 10 x64, and when I got to the part to choose where to install Windows, it sees all six drives with no problem.

Do I need a special driver for SSD drives attached to a PCIe controller?  Windows installer seems to see them as "regular drives".

Thanks for any guidance.

0 Kudos
4 Replies
Contributor
Contributor

I have got a similar situation. My main SSD is going out, so I bought a PCIe SATA card so I can hook up multiple SATA SSDs (aside from the 8-disk spinner RAID), for copying VMs, etc. I booted the system (Dell PowerEdge T430) and the drives were initially recognized but would not accept datastore creation. Then after another reboot, the drives aren't even recognized at all. I'm thinking it has to do with the drivers for the PCIe card but I'm having a heck of time finding anything useful.

0 Kudos
Enthusiast
Enthusiast

Have you seen this ?

https://www.virtuallyghetto.com/2019/05/quick-tip-crucial-nvme-ssd-not-recognized-by-esxi-6-7.html

You may need to use NVME driver from Vsphere 6.5 U2 in order to utilize non server grade NVMEs

0 Kudos
Contributor
Contributor

In my case, I'm using SATA 2.5 inch SSDs, not NVMe SSDs. Plus I'm on ESXi version 6.5...

My use-case is with a PCIe x4 card that has internal SATA jacks for connecting SATA devices on the board. I'll check out the reference either way, as I'm a bit stuck now.

Thanks.

0 Kudos
Immortal
Immortal

Your plan:

I am trying to install ESXi 6.5 on a Dell Precision Workstation.  The workstation is configured with:

  • two 512GB SATA SSD drives
  • four 1TB SSD drives connected to a PCIe card

probably fails because ESXi does not like your PCIe card with the extra sata slots. I would suggest to connect your 4 SSDs to the regular sata-slots and install ESXi to a USB-stick.

Do you need support with a recovery problem ? - call me via skype "sanbarrow"
0 Kudos