goueg83460
Contributor
Contributor

Cannot acces network with vlan Id configured on Vswitch

Hi, I'm trying to use vlan ID on Vswitch. But I'm not able to ping anything throught it.

I created a Vswitch with several vlan ID network label attached to a real network interface. On my switch I configured (Cisco 2900 series):

-


interface FastEthernet0/22

switchport mode trunk

!

-


But I'm not able to ping a host connected on same vlan and same real switch:

scheme:

| | -- 0/22 (trunk) -- Vswitch -- vlan 200 -- Host A

| | -- 0/20 Access vlan 200 -


HostB

Cisco Switch

The ping between Host A and Host B does not success. I hope someone will be able ti help me. If youy need more info feel free to ask me.

Thanks in advance.

0 Kudos
3 Replies
danm66
Expert
Expert

http://kb.vmware.com/kb/1004127

switchport mode access

spanning-tree portfast

goueg83460
Contributor
Contributor

ok thanks for your help. But I have several vlan configured on my Vswitch. So I think that trunk should be used. I read a doc and I think that I'm configuring the VST mode.

I mean with vlan 200 I have also vlan 110 and vlan 210 that should arrived in my Vswitch. This is why I thought that trunk mode should be configured.

0 Kudos
goueg83460
Contributor
Contributor

OK I try following conf and it works good now:

interface FastEthernet0/22

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

Anyway thanks for your help.

0 Kudos