mjwilcox
Contributor
Contributor

Can't find files on uploaded VM

I uploaded two VMs to a new ESXi 4.1 server (will be doing a total of 6 or 8 across two servers) and when I tried to start them I said they had been "moved". The next thing that popped up was an error:

Reason: The system cannot find the file specified.
Cannot open the disk '/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB/PUB 7.0-000006.vmdk' or one of the snapshot disks it depends on.
VMware ESX cannot find the virtual disk "PUB 7.0.vmdk". Verify the path is valid and try again.

even though that file does exist. Did the chmod on the files as suggested in a previous thread and still no joy. Output of ls -al and log file are below.

Any pointers would be very much appreciated.

Thanks,

Mike

/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB #  ls -al
drwxr-xr-x    1 root     root               3080 May  3 09:18 .
drwxr-xr-x    1 root     root                560 May  3 08:35 ..
-rwxr-xr-x    1 root     root         1040340992 May  3 07:24 PUB 7.0-000001-delta.vmdk
-rwxr-xr-x    1 root     root                296 May  3 07:24 PUB 7.0-000001.vmdk
-rwxr-xr-x    1 root     root          906123264 May  3 07:26 PUB 7.0-000005-delta.vmdk
-rwxr-xr-x    1 root     root                296 May  3 07:26 PUB 7.0-000005.vmdk
-rwxr-xr-x    1 root     root         4496447488 May  3 07:41 PUB 7.0-000006-delta.vmdk
-rwxr-xr-x    1 root     root                303 May  3 07:41 PUB 7.0-000006.vmdk
-rwxr-xr-x    1 root     root              28353 May  3 07:41 PUB 7.0-Snapshot1.vmsn
-rwxr-xr-x    1 root     root              28360 May  3 07:41 PUB 7.0-Snapshot2.vmsn
-rwxr-xr-x    1 root     root              28360 May  3 07:41 PUB 7.0-Snapshot5.vmsn
-rwxr-xr-x    1 root     root               8684 May  3 07:41 PUB 7.0.nvram
-rwxr-xr-x    1 root     root               1139 May  3 07:41 PUB 7.0.vmsd
-rwxr-xr-x    1 root     root               2887 May  3 08:49 PUB 7.0.vmx
-rwxr-xr-x    1 root     root                262 May  3 07:41 PUB 7.0.vmxf
-rwxr-xr-x    1 root     root              45418 May  3 07:41 vmware-46.log
-rwxr-xr-x    1 root     root              44825 May  3 07:41 vmware-47.log
-rwxr-xr-x    1 root     root              44828 May  3 07:41 vmware-48.log
-rwxr-xr-x    1 root     root              38089 May  3 08:49 vmware-49.log
-rwxr-xr-x    1 root     root              37130 May  3 08:55 vmware-50.log
-rwxr-xr-x    1 root     root              37130 May  3 08:57 vmware-51.log
-rw-r--r--    1 root     root              37128 May  3 09:18 vmware.log
/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB #

Tags (2)
0 Kudos
3 Replies
a_p_
Leadership
Leadership

From where and how did you upload these files.

  1. The base virtual disk "PUB 7.0.vmdk" and "PUB 7.0-flat.vmdk" is missing
  2. "PUB 7.0-000005.vmdk" and  "PUB 7.0-000005-delta.vmdk" are not even mentioned in the log fie.

André

0 Kudos
Walfordr
Expert
Expert

Your base disk is missing.  Find it and copy it over:

May 03 09:18:51.118: vmx| DISKLIB-LINK  : "/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB/PUB 7.0.vmdk" : failed to open (The system cannot find the file specified). 
May 03 09:18:51.118: vmx| DISKLIB-CHAIN :"/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB/PUB 7.0-000006.vmdk": Failed to open parent "/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB/PUB 7.0.vmdk": The system cannot find the file specified.
May 03 09:18:51.118: vmx| DISKLIB-CHAIN : "/vmfs/volumes/4dbeb0d0-140388a7-793c-d48564776670/CUCM/PUB/PUB 7.0.vmdk" : failed to open (The parent of this virtual disk could not be opened).


If you can afford to, I would recommend that you commit or delete the snapshots then move the VM.

Robert -- BSIT, VCP3/VCP4, A+, MCP (Wow I haven't updated my profile since 4.1 days) -- Please consider awarding points for "helpful" and/or "correct" answers.
0 Kudos
opbz
Hot Shot
Hot Shot

Your logs mention missing vmdk files.

have a look at the smaller vmdk files on your folder.

these are configuration files for vmdk. main things you are looking for here are the CID numbers (and parent CIDs) then parentfile hint names.

Can you post these smaller vmdk? I want to have a look at them to see if you a chance of recovering your data or not. Chances are you will have to make some changes to the config files and then you will need to consolidate the vmdk (vmdk files are checked for CID values and timestamps so if you edit one it will give you errors) Either ay if you end up editing the vmdk files you ussually risk having corruption..

If ms are still present on your older esx serer I would suggest you delete snapshots and then try copying them over...

0 Kudos