m4biz
Enthusiast
Enthusiast

Can't browse datastore on working ESXi server

Hi.

On my ESXi 5.0 all works fine but I can't browse the datastores.

datastore.png

Any idea?

 

Ing. Cosimo Mercuro http://cosimomercuro.wordpress.com/
Labels (1)
Tags (1)
0 Kudos
6 Replies
ashilkrishnan
VMware Employee
VMware Employee

Hi @m4biz ,

To begin with, I would like to say that it is advised not to be running any production/critical workloads on a legacy/unsupported ESXi version.

vSphere 5.0 is long gone. Consider upgrading to a supported version.

For the issue, it could be storage/storage performance issue. Please connect via SSH and run the following commands:

1. Datastore utilization:    df -h 

2. Try to access the datatsore:   cd  /vmfs/volumes/datastorename

3. If you can access, try creating a test folder:     mkdir test

0 Kudos
Lalegre
Virtuoso
Virtuoso

Hey @m4biz,

Am I seeing well or you have two datastores with the same name? Try what @ashilkrishnan propose you of checking from inside the ESXi OS but if that does not work give it a try of renaming one of the datastores as I do not know how do you have two with the same name as it is not possible.

0 Kudos
ashilkrishnan
VMware Employee
VMware Employee

@Lalegre ,

Interesting. I completely missed that out. 

m4biz
Enthusiast
Enthusiast

Hi.

sorry for delay.

Yes , the issue, I think, is related to the two datastores with the same name even if each datastore has a different hard drive (the server has two, different, physical drive):

First datastore HDDFirst datastore HDDSecond datastore HDDSecond datastore HDD

 

 

Ing. Cosimo Mercuro http://cosimomercuro.wordpress.com/
0 Kudos
Lalegre
Virtuoso
Virtuoso

Hey @m4biz,

Go to the datastore tab, right click on it and rename it.

After that try to browse again.

Regards!

0 Kudos
continuum
Immortal
Immortal

This post seems to be a test on the troubleshooting skills of the VMTN posse.
Thats a welcome change to the daily routine - I bite 😎

For arguments sake lets assume the screenshots posted here are NOT carefully photoshopped to be misguiding.

If yes - then the answer is simple: you cant browse datastore because you have no VMFS-volumes at all.
See screenshots with the partition-tables !
On ESXi 5 the expected partition-number of a VMFS-volume is 1 or 3.
Please post screenshots that proove that you actually have VMFS-partitions. 😏

Ulli



________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos