marioarias
Contributor
Contributor

Can't Delete Corrupt Virtual Machine

One of our Virtual Machine's has become corrupt, I tried to remove it to restore it using VMware Data Recovery 1.0 appliance with unsuccessful results.  I have tried to remove it from command line with unsuccessful results as well.

The message that I get when I try to remove it from inventory in vcenter is:

"A general system error occurred:Invalid fault"

The VM won't turn on, I tried to remove it from the datastore manually and I can't do that either.

I tried to recover it by using VDR and restoring it as a different VM in a different datastore and have not been successful either.  I can recover other VMs but not this one.

Does anyone have any ideas?

Thank You,

Mario

0 Kudos
2 Replies
dan13476
Contributor
Contributor

Restart the management services on the host that the vm is on. In esxi5 type "services.sh restart".

You will momentarily lose access to the host. (other vms stay running)

That should free up the vm so that you can properly delete it from the vsphere client.

Dan.

0 Kudos

follow what dan said, restart the management agents, either by services.sh or using the mangement agent reset in the console.

If that wont work then try a reboot of the host itself. vmotion off the other vms of course...

--------------------- Sparrowangelstechnology : Vmware lover http://sparrowangelstechnology.blogspot.com
0 Kudos