Highlighted
Contributor
Contributor

Can not connect with SSH from local network.

Hello there.

I am pretty new to ESXI 6, i have installed it today on my HP Proliant DL160 G6 without any problems.

I've created an VPS and installed Ubuntu Server 14.04.02 x64.

I have found some information in Google, check this out: http://www.thomasmaurer.ch/2011/08/enable-ssh-on-esxi-5-via-vsphere-client/

Here is a screenshots of my Client:

Untitled.png

Untitled2.png

The local IP for the VPS that i am trying to connect is 192.168.1.96. I have tested ping in CMD to 192.168.1.96 i have no problems.

I am trying to connect to the VPS with Putty and here is the error i got from Putty when trying to connect to the VPS:

Untitled3.png

The port on which i am testing it is 22.

Can you please help me out ?

Thanks in advance!

Tags (3)
0 Kudos
6 Replies
Highlighted
Enthusiast
Enthusiast

Did you checked as allowed incoming port 22 at the SSH server?:

pastedImage_0.png

0 Kudos
Highlighted
Contributor
Contributor

It is the same as yours! But still it is not working.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Are you trying to connect to the Ubuntu VM or to the ESX host?

0 Kudos
Highlighted
Contributor
Contributor

I am trying to connect to the Ubuntu VM. The ESXI host is with local ip 192.168.1.98.

I am trying to connect to ip 192.168.1.96 which is the local ip of the Ubuntu VM.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Sorry cause the screenshots from the VMware client confused me as these settings have nothing to do with the ssh access to the Ubuntu VM.

I assume when you installed the Ubuntu VM you have specified to allow the incoming ssh connections and also installed the ssh server on it.

This is purely OS issue of the VM since you can ping it.

I am not familiar with Ubuntu to tell you the commands you need to run but check for /etc/sshd to confirm the ssh server is installed and as a quick fix try to disable the firewall of the UB server.

Brgds

0 Kudos
Highlighted
Hot Shot
Hot Shot

this should help you setup SSH for the ubuntu VM.

http://ubuntuhandbook.org/index.php/2014/04/enable-ssh-ubuntu-14-04-trusty-tahr/

The firewall configuration you went through above was to allow ssh to the esx server, so its not applicable.

Rich

0 Kudos