xavvijay
Contributor
Contributor

CPU doesn't support long mode.

Jump to solution

Hi

I have vmware ESXi 4.0 installed on a HP dektop. I already have 3 VM's running (presumably 32 bits), but today when I tried to Install FreeBSD 64 bit and CentOS 64 bit, I get the following error "CPU doesn't support long mode". or "use a 32 bit version"

I find this kind of starange becos, ESXi4 installs only on 64 bit processors. So my processor supports 64 bit, but whu not the guest OS.

(oh.. any my processor is Core i7)

Is there something I am missing?

Thanks

Antonio

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
DSTAVERT
Immortal
Immortal

Does the BIOS support VT. The VT option is most often disabled. There are other options in the BIOS that may also be set but try that first

-- David -- VMware Communities Moderator

View solution in original post

0 Kudos
4 Replies
DSTAVERT
Immortal
Immortal

Does the BIOS support VT. The VT option is most often disabled. There are other options in the BIOS that may also be set but try that first

-- David -- VMware Communities Moderator
0 Kudos
xavvijay
Contributor
Contributor

Wow... that was damn fast!!!!

Yes u were right....when I enabled that feature, it started it work....thank u so much for ur help....

0 Kudos
DSTAVERT
Immortal
Immortal

Quite welcome.

-- David -- VMware Communities Moderator
0 Kudos

If you consider any comment as helpful, please award points Smiley Happy


---

MCSA, MCTS, VCP, VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos